Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a new Crucial M4 128 GB Sata 3 solid state drive that i cloned my OS on to. I have a laptop with two 500 GB drives, one holding the OS and one holding data. I swap the os drive with the SSD and i get an error on boot "BOOTMGR is Missing". I tried loading from a system restore disk and when it loads it does not show the OS on the SSD in the list of OS when it first loads.

tried the following commands in cmd:

BOOTREC /FIXMBR - success

BOOTREC /FIXBOOT - element not found

BOOTREC /REBUILDBCD - finds os but when i try to enter Y or Yes to add to boot list it returns element not found

BOOTREC /SCANOS - Finds OS

I also used diskpart to make sure the partition is active on the drive so i am at a loss for what else can be done to make it work.

My laptop is an Asus G72GX if that makes any difference.

share|improve this question
1  
It sounds like you copied the wrong hdd. –  Ramhound Aug 28 '12 at 13:02
    
no i copied the right one, all the OS files are on the drive when i connect it via USB. And both BOOTREC /REBUILDBCD and BOOTREC /SCANOS see the OS as well. –  jardane Aug 28 '12 at 13:07
    
How exactly did you "Clone" it? –  Ƭᴇcʜιᴇ007 Aug 28 '12 at 13:13
    
i used a program called "EaseUS Partition Master" –  jardane Aug 28 '12 at 13:27

1 Answer 1

I was in a similar situation after cloning a hard drive to an SSD. The annoying part is that when I had both disks in the system, it would still boot to the old disk--independent of the boot sequence, but only if I had the windows repair disk in the CD drive (or maybe any CD, not sure).

The cure that worked for me was to use a Windows Repair disk with the older original drive physically disconnected from the system. Just boot into Windows Repair, choose the OP system and use the "Repair Startup" to write a new BCD automatically. Worked great once I had the guts to try it. (I had try'ed numerous times with the org disk still in the drive but it was causing drive letter to be wrong or writing to the wrong place because it would never work.)

I was then able to put the original disk back in the system and it boots fine now. I believe there are physically two copies of the BCD now and if either of my disks is removed I think it will start. Kind of neat. Some may argue saying its not possible but the facts are leaning the other way.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.