Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I start up IE (9.0.8112.16421) with about:blank and I go to ftp://ftp.microsoft.com/

I press Alt, click View and then Open FTP Site in Windows Explorer. At this point IE stops responding and eventually crashes (though the window is still active, sometimes) and I get the usual Windows dialog box saying that the program has stopped working.

From this dialog box I click on the option to try to find solutions to the problem and the progress bar just keeps scrolling without giving me any result page whatsoever, so I have to abort by clicking Cancel.

Then I get the bubble type of pop-up message from the system tray saying that DEP has stopped the program from executing.

What gives? Why would DEP (part of Microsoft Windows) be preventing IE (a Microsoft product) from performing a perfectly legitimate action from Microsoft's own FTP site?

The OS is Windows Vista HP SP2, Swedish locale.

Screenshots as follows...

microsoft ftp in ie 9 screen 1

microosft ftp in ie 9 screen 2

microosft ftp in ie 9 screen 3

microsoft ftp in ie 9 screen 4

Update: I normally have UAC disabled, but I have discovered that enabling it has an effect on IE when I click the FTP option from the View menu, just as I suspected.

I basically tried starting IE in its 32-bit and 64-bit version, with and without add-ons, and switching UAC on and off, and then trying to go to View and the FTP option (as shown above). Here are the results.

With UAC off and DEP on

Action: IE 32-bit, normal start, go to ftp://ftp.microsoft.com/, view menu, FTP option.
Result: crash

Action: IE 32-bit, extoff, go to ftp://ftp.microsoft.com/, view menu, FTP option.
Result: crash

Action: IE 64-bit, normal start, go to ftp://ftp.microsoft.com/, view menu, FTP option.
Result: information & warning message

Action: IE 64-bit, extoff, go to ftp://ftp.microsoft.com/, view menu, FTP option.
Result: information & warning message

This is the information and warning message I get if I use IE 64-bit: microsoft ftp in ie 9 screen 5

microsoft ftp in ie 9 screen 6

The first message is an FTP proxy warning. It says that the folder ftp://ftp.microsoft.com/ will be write-protected because proxy server is not configured to allow full access. It goes on to say that if I want to move, paste, change name or delete files I must use another type of proxy, and that I should contact the system admin for more information (the usual recommendation when they have no clue of what's going on).

What the heck is all this about? I don't even use a proxy server, as you can see from the next screenshot (Internet Options, Connections, LAN settings dialog).

microsoft ftp in ie 9 screen 7

That second message only states that the FTP site cannot be viewed in (Windows) Explorer.

With UAC off, I always get these two messages when running the 64-bit version of IE.

With UAC on and DEP on

Action: IE 32-bit, normal start, go to ftp://ftp.microsoft.com/, view menu, FTP option.
Result: crash

Action: IE 32-bit, extoff, go to ftp://ftp.microsoft.com/, view menu, FTP option.
Result: security warning message, prompts to allow action

Action: IE 64-bit, normal start, go to ftp://ftp.microsoft.com/, view menu, FTP option.
Result: security warning message, prompts to allow action

Action: IE 64-bit, extoff, go to ftp://ftp.microsoft.com/, view menu, FTP option.
Result: security warning message, prompts to allow action

As you can see from this list, if I have UAC enabled I actually get rid of these messages and opening the FTP site in Windows Explorer (from IE) actually works (except for 32-bit version which still crashes).

Here is the security warning message: microsoft ftp in ie 9 screen 8

The fact that the 32-bit IE still crashes could be an indicator that this has something to do with one or several add-ons in that bit-version of IE. The 32-bit IE doesn't crash if it's started with the extoff flag.

If this is affecting only the 32-bit IE then it's only normal that the 64-bit IE doesn't have this problem because it would not be using any of the add-ons used by the 32-bit version, they are not compatible with 64-bit (although some add-ons work both with 32-bit and 64-bit IE).

Figuring out which add-on (if any) is causing this problem is a whole new question... but I seem to be closer to an answer now, and a possible solution.

I could of course just add IE (32-bit) in the exclusion list of DEP. In fact, I have already tested this and it causes IE to perform this task without hiccups. But I don't really want to disable DEP, or force it on all Windows programs and services (except the ones I strictly specify in the exception list). (In other words DEP can't really be completely disabled, you can only switch between two modes of operation.)

microsoft ftp in ie 9 screen 9

Update 2: This is interesting...

I start 32-bit IE, go to ftp://ftp.microsoft.com/ and click on View, and Open FTP Site in Windows Explorer. The result is a crash!!

Then I start 32-bit IE with extoff flag to disable add-ons, I go to ftp://ftp.microsoft.com/ and click on View, and Open FTP Site in Windows Explorer. I get the security warning, as expected with UAC enabled, and it opens up in Windows Explorer.

Now... I close Windows Explorer, and I close IE. I then start 32-bit IE (normal start, with add-ons), I go to ftp://ftp.microsoft.com/ and click on View, and Open FTP Site in Windows Explorer. Now this time it doesn't crash! Instead, I get the screenshot number 5 as seen above. This is the FTP proxy warning message. Now get this... if I click the close button to get rid of this message, what happens is that Firefox starts up, and it goes to ftp://ftp.microsoft.com/

The fact that this works with 32-bit IE (with add-ons) the second time around, is because I am still logged in as anonymous to the FTP server. The log-in has not timed out yet. Standard log-in timeout for FTP servers is usually 60 to 120 seconds. I got logged in to it the first time I ran 32-bit IE with the extoff flag (no add-ons) which actually works and connects using Windows Explorer.

Update 3: The connection to the FTP server has timed out by now. So now if I run 32-bit IE (with add-ons) and repeat the steps as before it crashes, just as expected...

In conclusion:

  • If I have already been connected to the FTP server via Windows Explorer, and I go to this FTP address in 32-bit IE and I pick the FTP option from the view menu to open it in Windows Explorer, it gives me a FTP proxy server warning and then opens the address in default web browser (Firefox in my case).

  • If I have not been connected to the FTP server via Windows Explorer previously, and I go to this FTP address in 32-bit IE and I pick the FTP option from the view menu top open it in Windows Explorer, then it crashes IE!

This is just great...

It's not that I care much for using Internet Explorer or the Windows Explorer to log in to FTP servers. This just shows why IE is not the best browser choice.

This reminds me of the time when Microsoft was enforcing the use of Internet Explorer as default browser for opening web links and other web resources, despite the fact that the user had installed an alternative browser on the system.

Even if the user explicitly set the default browser to be something else and not Internet Explorer in the Windows options, IE would still pop up sometimes, depending on what web resources the user was trying to access. Setting default browser had no effect. It was hard-coded that IE is the browser of choice, especially when accessing Microsoft product or help pages. The web page would actually say that you are not using IE, and that you must open it in IE to view it. Unfortunately you would not be able to open it manually in a different browser by simply copying and pasting the URL from the address bar, because it would show a different URL, and the original URL would re-direct to the "you are using the wrong browser" page so you would not have the time to cut it to clipboard.

Thankfully those days are over. Now-days Microsoft is forced to distribute IE and WMP free versions of Windows for the EU market. The way it should be! These programs have to be optional, not mandatory.

share|improve this question
    
Could someone on Windows Vista or Windows 7 please try to replicate this? I would appreciate if you could tell me if this works on your system. –  sammyg Aug 28 '12 at 13:55
    
In case you wonder, this step is necessary to log on to a given FTP site. You have to open the FTP in Windows Explorer, then you press Alt and click File menu and you get the option to log in to the FTP in order to upload files. –  sammyg Aug 28 '12 at 13:56
1  
I have windows 7 and that feature works fine for me. –  Scott Chamberlain Aug 28 '12 at 14:01
1  
What is your question? –  Daniel Beck Aug 28 '12 at 15:22
    
@DanielBeck Are you saying that you don't understand the question? –  sammyg Aug 28 '12 at 15:57

2 Answers 2

This could be some plug in to IE, not IE itself. Check to see what plug-ins (most likely some vendor's tool bar) and disable it and see if you still get the error.

If you remove all plugins and you still get the issue IE is likely corrupt and you should either restore from a backup or re-install windows.

share|improve this answer
    
Thanks, I'll try that. –  sammyg Aug 28 '12 at 13:40
    
After seeing your screenshots check to see if it still happens if you totally close Kerpersky too. –  Scott Chamberlain Aug 28 '12 at 13:45
    
I used the settings dialog in IE to set my start page to about:NoAdd-ons, saved the new settings and restarted IE. This however didn't help. Even without add-ons, IE keeps crashing when choosing that option from the View menu. –  sammyg Aug 28 '12 at 13:46
    
I just found that one can also run iexplore -extoff from the run prompt to start IE without add-ons. Unfortunately it had the same effect. Is there a way to start IE in even "more" safer way? Some other run command I can try? –  sammyg Aug 28 '12 at 13:49
    
Try closing your anti-virus, firewall, any other program that could be monitoring/changing what happens inside IE and see if it still happens. After that, start windows in Safe Mode, after that its likely time to re-install. –  Scott Chamberlain Aug 28 '12 at 13:52

When you click that option in Internet Explorer, Windows Explorer is started out of the sandbox Internet Explorer is living in. Usually this causes this warning to appear:

enter image description here

I don't know why exactly DEP decides to shut the process down, but I'd try to access the server directly from Windows Explorer to avoid the whole mess.

If you want further details, I'd recommend snooping around with Process Monitor and checking what actually happens when IE freezes.

share|improve this answer
    
What processes or events should I be looking for in the Process Monitor? –  sammyg Aug 30 '12 at 17:52
    
I now also get the Internet Explorer Security message you posted in the screenshot. I got this after activating UAC. I will shortly post my new findings in the original post. –  sammyg Aug 30 '12 at 17:54
    
@Sammy: Oh interesting. Please @notify me when you update. I'm interested :) –  Oliver Salzburg Aug 30 '12 at 18:25
    
I have updated the original post now. –  sammyg Aug 30 '12 at 19:43
    
@Sammy: What happens on my machine after "that proxy message" is that the FTP site is opened in Chrome. This leads me to the following conclusion. The warning message basically tells you, that you can't access that page with Windows Explorer and that instead, it should be opened with Internet Explorer. So it tries to open that same FTP site in the web browser. Mine is Chrome. Yours is IE. So! IE opens WinExplorer, which then again opens IE. This all mixed with 32/64 bit differences... Good luck :D –  Oliver Salzburg Aug 30 '12 at 21:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.