Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to following the to mount an img file on ubuntu:

http://askubuntu.com/questions/129305/how-can-i-open-binary-image-files-img

But when I do 'sudo mount -o test.img /mnt/disk'

 $ sudo mount -o  test.img  /mnt/disk
mount: can't find /mnt/disk in /etc/fstab or /etc/mtab

Can you please tell me how can fix that?

share|improve this question

2 Answers 2

You forgot to actually give the options to -o. Because of that, mount interprets "test.img" as the options, and not as the disk/image to mount.

sudo mount -o loop test.img /mnt/disk
share|improve this answer
1  
On recent Linuxes, -o loop is not necessary anymore: sudo mount test.img /mnt/disk –  grawity Aug 28 '12 at 14:04
    
Thanks. I try that. And it said 'mount: you must specify the filesystem type'. My img is a image file for android. Can you please tell me what filesystem I should use? thanks. –  michael Aug 28 '12 at 15:36

Maybe the right way to do it would be to convert img file to iso and than mount it as loop device.

http://ubuntuforums.org/showthread.php?t=1686904

according to this thread

you forgot to add "loop"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.