Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two external harddrives which I'm using for archiving purposes, because of that they are turned off most of the time. I have some shortcuts on the desktop to some directories on these external harddisks.

Windows occasionally removes these desktop shortcuts. It happens when the harddisks are turned off. I think it thinks that the shortcuts are broken and no longer needed, and tries to clean the desktop up.

How do I prevent this behavior?

(OS Version: Windows 7 Ultimate x64 SP1)

share|improve this question
    
FTR: This seems to also affect shortcuts on network shares. That's how I found this question, and it seems to work! –  Canadian Luke Mar 13 at 16:52

2 Answers 2

up vote 2 down vote accepted

maybe the solution hereunder helps you

http://lifehacker.com/5505466/stop-windows-7-from-deleting-your-desktop-shortcuts

it’s possible to disable the System Maintenance troubleshooter. To do this, click Start followed by Control Panel. Now click the ‘Find and fix problems’ link under the System and Security heading.

Finally, click Change settings in the navigation pane on the left and then click the Off radio button under the Computer Maintenance heading.

share|improve this answer

We have had this problem at work for a long time and I am not sure what it is that happens when disabling the "Computer maintenance" task. Instead I found this hotfix from Microsoft: KB2642357

Use regedit and add a new DWORD called IsBrokenShortcutsTSEnabled in HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\ScheduledDiagnostics\

Set the value to 0

You can also download a tool from the page that the link points to which will do it automatically for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.