Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I restart a shell session from within SSH when it looks something like this:

anton@ubuntu:~$ c: command not found
                                    anton@ubuntu:~$ lib
                                                       anton@ubuntu:~$ this is working, but its messed up
                         anton@ubuntu:~$

I can execute commands, but as I input them nothing shows on the console. But as soon as I press Enter the command executes and the output comes (without line-endings, as shown above).

exec bash
bash --login
clear

Nothing really works, restarting the SSH session however works. The temporary solution is to start a screen session and every time the interface freezes you simply do Ctrl+a->c to start a new session and close the old one.

share|improve this question
    
Try stty sane –  grawity Aug 29 '12 at 8:42
    
Worked some what, after doing it if you press the mouse something like: A2#A2 or N1#N1 comes up :) –  Torxed Aug 29 '12 at 8:55
add comment

1 Answer

up vote 4 down vote accepted

The command reset might help. See man reset for details, but simple reset should be just fine.

share|improve this answer
    
This worked perfectly! Thank you! –  Torxed Aug 29 '12 at 8:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.