Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just got a new laptop, and for the most part have left its settings alone. Today I was trying to get some sharing going between my desktop and the laptop. Both machines are connected to the same wireless network and both machines consider that network to be a Home network. Both are running Win7 Home Premium.

It seems like my laptop is aware of my desktop on the network. It can ping it by IP or by computer name. When I go to Network from the laptop, I can see the desktop in the list of computers. However, my desktop cannot ping the laptop, nor can it see it within Network. My desktop has a Homegroup set up, but my laptop says "There is currently no homegroup on the network".

I do have network discovery turned on for both machines.

Why can my desktop not "talk" to my laptop but it works the other way around?

Update:
Disabling the Windows Firewall on the laptop somewhat fixes the problem. With it disabled, my desktop can ping my laptop, but still my laptop can't see the homegroup. Also, it can ping via hostname, which resolves to IPv6, but can't ping via the IPv4 address. Obviously I'd rather not leave my firewall disabled, so I need a more specific fix.

Update 2: Aha! It is the Cisco VPN software I was running to connect to work computers. Once I disconnected and exited from that, the two PCs seemed to be talking normally and the homegroup was visible to the laptop.

So now my question has morphed: how can I prevent Cisco VPN from interrupting my home networking?

share|improve this question
    
Can you confirm that both sharing and security allows all to see/share. They are different things. –  Dave Aug 29 '12 at 13:43
    
@DaveRook can you clarify what you mean by sharing and security? What settings / screens are you referring to? –  RationalGeek Aug 29 '12 at 13:52
1  
Right click on the users folder and update both the sharing and security tab. Try adding everyone with full rights just to see if this helps. –  Dave Aug 29 '12 at 14:08

2 Answers 2

up vote 1 down vote accepted

If you are disconnected from your local network while connected to a remote network via VPN this is most likely a intentionally configuration specified by the admins of the VPN.

The only possibility to circumvent this setting is not to use Cisco VPN client. There are free alternatives like Shrewsoft VPN client which are compatible with Cisco VPN and that are also able to read common Cisco VPN profile files.

However you have to be aware that using a different VPN client that does ignore the VPN policy set by the VPN admins may violate your corporate policies (if the VPN belongs to a coprorate) - and violating a policy may result in consequences if someone notices what you are doing.

share|improve this answer
    
Thanks for the info. If this is the policy then I am okay (but annoyed) with following it. Is there some way to confirm that this is an intentional policy and not some accidental conflict? –  RationalGeek Aug 29 '12 at 14:32

First check in both computers if all the network profiles are set to Home? You can also try deleting the homegroup and creating a new one. Here is some helpful information.

Why can't I join a homegroup? - http://goo.gl/fhjjj

Windows 7 HomeGroup: Frequently Asked Questions - http://goo.gl/EQmK

share|improve this answer
    
Checked all of this stuff. It was all set up correctly. Turns out to be related to VPN. See my updates and new question. –  RationalGeek Aug 29 '12 at 14:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.