Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every few minutes Visual Studio will completely go crazy.

enter image description here

  • The content of tabs is offset.
  • Code is not drawn at all.
  • Clicking on tabs does nothing.
  • Toolbox windows are also not rendered correctly

Only resizing the window temporarily fixes the issue, but only for a few more minutes and then it corrupts again.

share|improve this question

1 Answer 1

up vote 8 down vote accepted

When experiencing graphical issues inside of Visual Studio, it can often be attributed to the use of hardware accelerated graphics. Thus, try disabling it.

  1. Go to Tools then Options:

    enter image description here

  2. The setting you're looking for is located in the Environment section:

    enter image description here

share|improve this answer
Good one to know! I've disabled it on mine now, curious to see if it results in less crashes/hangs/frustration. – Amicable Aug 29 '12 at 14:34
In my case, the issue persists even after disabling hardware acceleration. Disabling the rich client visual experience also doesn't fix it. – Oliver Salzburg Aug 31 '12 at 10:40
I can't believe 3 years later and this is still an issue. On my dual monitor setup, I always had redraw issues when dragging it to my DisplayPort monitor. This solved it perfectly. – Aaron Jun 2 at 13:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.