Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I had been using Ubuntu for quite sometime and recently installed CentOS and getting the below error when I update using yum. How do I resolve such errors?

Dependency Resolution Errors:
Package: gstreamer-plugins-bad-0.10.19-3.el6.rf.x86_64 (@rpmforge)  
    Requires: libmodplug.so.0()(64bit)  
    Removing: libmodplug-0.8.7-1.el6.rf.x86_64 (@rpmforge)  
        libmodplug.so.0()(64bit)  
    Updated By: 1:libmodplug-0.8.8.3-2.el6.x86_64 (epel)  
        Not found 
share|improve this question

1 Answer 1

It's been a while since I've run CentOS, so my memory's fuzzy, but it looks to me like there are a couple of possible problems:

First, it looks like you're using both EPEL and RPMforge (now known as Repoforge). I don't think that those two repos are guaranteed to work together; you might want to try disabling EPEL to see if your problem goes away. (This question discusses EPEL versus RPMforge in more detail.)

Second, the "not found" error while trying to install the EPEL version of libmodplug makes it sound like there might be a problem with your EPEL config or your access to EPEL repositories. I'm not sure.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.