Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I use the MDR in BeOS R5 to send/receive through Gmail no problem, but on Haiku it says, "No reply." Is it because there are no SSL options in the e-mail prefs under Haiku? How do I enable them?

share|improve this question
add comment

2 Answers

Yes, Gmail only accepts SSL connections to its IMAP and POP3 services.

If the mail client doesn't support SSL, a workaround might be to install stunnel (if you can get it to run on Haiku, or have a spare Linux/Windows box), then add a service like this, to stunnel.conf:

[gmail-imap]
accept = 143
client = yes
connect = imap.gmail.com:993

Then set up MDR to connect to localhost:143 without SSL. (Of course, replace localhost with the address of your stunnel server, if that's different.)

share|improve this answer
    
That's the weird thing--the MDR for BeOS is the same one that ended up in the Haiku branch, and Haiku comes with OpenSSL, so it should actually support it. I'll look into stunnel though, thanks for the lead. –  Kev Sep 25 '09 at 18:45
    
I don't think stunnel is available on haiku, nor do I have the skills to get it to compile. I also don't have a spare box. :| –  Kev Sep 25 '09 at 18:52
add comment
up vote 2 down vote accepted

It now works on the latest nightly (SSL is an option in the prefs.)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.