Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I currently have SVN server installed on my Linux Ubuntu machine, version 1.6.12.

I see that the latest version is 1.8.x and would like to update my installation to it, so I run:

sudo apt-get update
sudo apt-get install subversion
svnserve --version

And it's telling me that it's still running version 1.6.12...

What's going on here?!? How do I actually update my installation through apt-get?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

apt-get searches for the updates in the repositories created for your version of Ubuntu. The SVN server version is not likely going to change until you upgrade the whole system.

share|improve this answer
    
Thanks @choroba (+1) - so you mean running sudo apt-get install * instead of sudo apt-get install subversion, or do you mean something else? Thanks again! –  pnongrata Aug 29 '12 at 22:42
1  
No, to upgrade your distribution, you should use apt-get dist-upgrade. It involves changing sources of all the repositories, takes a lot of time and can break things. Be careful, make yourself sure you really want it. –  choroba Aug 29 '12 at 22:48
    
Ahhh gotchya, well... I'm using the latest version of Ubuntu (12.04) - so I don't think the distro version is the issue. It should have the latest version of SVN in it... –  pnongrata Aug 29 '12 at 22:54
    
According to packages.ubuntu.com/precise/devel/subversion, 12.04 should use subversion 1.6.17. Are you calling the right svnserve in /usr/bin? –  choroba Aug 29 '12 at 23:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.