Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows 7, you get a fair bit of control over how pictures are imported (e.g. when you connect a camera or SD card). Specifically, it lets you choose the folder structure that you'd like. For instance, you can have folders be created to match the dates that pictures were taken, which goes a long way to keeping things organized.

But in Windows 8, I have not been able to locate the equivalent settings. The 'Photos' app handles the Import, and the only thing it asks is the folder name where you want everything to get dropped, regardless of the date they were taken.

Is there a way to do this? I've been able to do everything I needed in Windows 8... until I hit this :)

share|improve this question
    
I can't add an answer as I don't have enough rep - but the way I solved it was to right click the Pictures Library in the Libraries area of Windows Explorer and add in/remove folder that you want don't want. Not sure how it would work if you entered multiple; but with one the import now sends it to that directory. –  DarrylGodden Apr 23 '13 at 7:08

3 Answers 3

up vote 16 down vote accepted

For Cameras, Phones, and Connected Devices

  • Open Explorer to Computer
  • Right-click on the device you connected (camera, iPhone, etc.))
  • Select on Import pictures and videos
  • Import Adjust the settings as you want

enter image description here

enter image description here

enter image description here

For SD cards

  • Rightclick on the removable disk
  • Select Open as Portable Device
  • Rightclick on the portable device in the folder pane to see the import option. If you rightclick on the portable device in the main view it doesn't give you the option, but does by rightclicking in the folder list.
share|improve this answer
    
Interesting, that does work when connecting a camera, but not an SD card containing pictures. I normally take the SD card out and put it in the computer to preserve the camera's battery life. In any case, that provides a workaround. –  David Ebbo Aug 30 '12 at 15:47
    
For an SD Card, right click and open as portable device –  pratnala Nov 29 '12 at 8:53
    
Great - but how can I make this the default action under Windows 8? –  Daniel Gehriger Mar 22 '13 at 11:24

Someone answered a very similar question I posed elsewhere with the following helpful solution:

You can get the "old" functionality back by creating a shortcut:

  1. right-click desktop, "new shortcut"

  2. paste the following in as the location:

    %SystemRoot%\system32\rundll32.exe "%SystemDrive%\Program Files\Windows Photo Viewer\photoAcq.dll",PhotoAndVideoAcquire

  3. hit next and type a name - e.g. photo import wizard

  4. hit finish

now you should have a shortcut and when you double-click it, you should see a list of connected devices that you can import photos from

share|improve this answer
    
I assume this is the tool for importing from devices that Al Bundy's answer refers to. Is there a similar command for the Open as Portable Device dialog? How did you work out how to do this? –  Sam Hasler Dec 9 '13 at 14:35
    
It looks like it might be in wpdshext.dll: nirsoft.net/dll_information/windows8/wpdshext_dll.html –  Sam Hasler Dec 9 '13 at 15:09

I also use and SD card. I found when that SD card appeared as a drive in Win 8, I could right click that drive and select "Open as Portable Device."

This caused what looked like a second drive of the same name (with no letter assigned) to appear below the SD drive. When I right clicked this second SD drive I had the option to "Import pictures and videos." When I selected this there was a "More Options" link I could click that brought me to the familiar import settings we all recognize from Win 7.

share|improve this answer
1  
Strange, that didn't work for me. I was able to do "Open as portable device", but right clicking that doesn't give me the "import..." option. –  David Ebbo Nov 11 '12 at 4:23

protected by Community Jan 18 '13 at 22:17

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.