Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have created a temporary certificate.
I am trying to import this certificate.I am importing Certificate to Personnel store of Local Computer and then using FindPrivateKey solution to find privatekey file.

Th problem is after going to the private key file I am unable to set security permission for the ASP.NET process.
I tried using cacls.exe, but it threw exception - "It can be used only on NTFS drive". I tried changing use Simple File sharing from Tools - options - FileType , but still I am not able to set permission. Following command I am running:

cacls.exe "C:\Documents and Settings\All Users\Application Data\Microsoft\Crypto\RSA\MachineKeys533857c8564c40d87fe9c8bcef94827b_e74230a4-859f-4b07-9ece-dd19ba319af7" /E /G "MYPC\ASPNET":R  

and getting following error:

The Cacls command can be run only on disk that use the NTFS file system

My Os is Windows xp and FileSystem is FAT.

share|improve this question

migrated from stackoverflow.com Aug 30 '12 at 7:15

This question came from our site for professional and enthusiast programmers.

    
can you show the complete cacls command you used and it's exact output? –  rene Aug 16 '12 at 12:47
    
What do you mean with "I am unable to set security permission for the ASP.NET process"? What exactly do you want to achieve? And why is the certificate relevant? Do you want to activate SSL? Or do you want to change the access rights for the file? –  Werner Henze Aug 21 '12 at 10:50

3 Answers 3

You could give winhttpcertcfg a try.

This command grants access to the private key of the "MyCertificate" certificate in the "My" certificate store for the TESTUSER account.

winhttpcertcfg -g -c LOCAL_MACHINE\My -s MyCertificate -a TESTUSER

http://msdn.microsoft.com/en-us/library/windows/desktop/aa384088(v=vs.85).aspx

share|improve this answer

It looks to me like the answer is in your question.

If your attempting to set permissions on a drive that is FAT32 then you wont be able to. FAT32 does not support permissions. You will need to convert the drive to NTFS.

share|improve this answer

The REAL solution is not the other two answers. If the key is not marked exportable you must put the certificate in the COMPUTER store, you state in your question that you put it in your personal store.

Open MMC and add the Certificate snap in. Set it to the Computer store and add the certifiacate. You will now be able to use the cert in IIS.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.