Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I used Putty to login into a Linux server.

The "problem" that in MC I see "a with ^", and not "|" in table.

How can I change this in putty to I see the MC as in Norton Commander/DOS.

share|improve this question
    
In Putty's config window, try to fix the character encoding and font. –  choroba Aug 30 '12 at 9:24
add comment

1 Answer

up vote 1 down vote accepted

As choroba's comment says,

The terminal-emulator and the server must agree about the character set and encoding that is being used.

On Linux you need to check what the environment variable $LANG is set to. There are other environment variable that can influence this but setting $LANG should work. e.g. export LANG=en_US.UTF-8

On Putty you change settings -> Windows -> Translation -> Remote character set. e.g. UTF8. You may also need to specify a font that contains the specific characters used by MC.

If MC ignores LANG and uses a specific character set (e.g. CP850 or CP437), you'd have to change Putty settings to match that.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.