Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Fresh install of Ubuntu Server 12.04 with Samba. The share is setup as follows:

[share]
    comment = My Share
    path = /srv/samba/share
    browsable = yes
    guest ok = no
    read only = no
    create mask = 2775
    directory mask = 0775
    write list = @group1

The directory /srv/samba/share has permissions 777 and is owned by user1:group1.

I have user2 and user3, both of whom have group1 as their primary group.

groups user2
user2 : group1

groups user3
user3 : group1

The problem I'm having is that user1 & user2 can access the share just fine, but not user3 (connecting from Windows 7). user3 can see the share, but can't get past the login prompt. user3 can ssh into the same server no problem. The /var/log/samba/smbd.log doesn't show anything related to this. I'm at a loss because I'm not really where to look to troubleshoot this further. Help!

share|improve this question
    
What OS are other users connecting from? Have you tried resetting user3's Samba password? (use smbpasswd, Samba has a separate database.) –  grawity Aug 30 '12 at 17:11
    
That was the problem. I didn't realize there was an smbpasswd. The thing that threw me off is that I never used smbpasswd for user1 & user2 so I'm still confused. But setting smbpasswd fixed it. –  SlyMcFly Aug 30 '12 at 17:35

1 Answer 1

up vote 0 down vote accepted

It's possible that the Unix and Samba account databases have different passwords for user3, or that Samba is lacking the account completely. Use smbpasswd to fix it.

You can enable pam_smbpasswd.so in PAM, which will automatically update the Samba account every time the user logs in locally or over SSH. (Of course, won't work with public-key logins.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.