Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm working in a Word 2010 document from a SharePoint document library. When you use the "Insert Hyperlink" command (or Ctrl+K) to add a hyperlink to text in the document, by default, the Insert Hyperlink dialog opens onto the directory where your file is saved. Because my document is stored in SharePoint, this means that the dialog must connect to the WebDAV folder where the document is stored, an operation that can take between 10 and 30 seconds every time I open the dialog. I have to insert hundreds of links into this document, so these delays are unworkable.

Is there a way to make Word use a different directory as the current folder in the Insert Hyperlink dialog so I don't have to go through this? Alternately, is there a good way to avoid the dialog entirely when adding hyperlinks? All my links are Web URLs, so I never even need access to the local file system anyway.

share|improve this question
up vote 1 down vote accepted

If you browse another folder once and click OK, this is saved for next time.

But if you want to link to WebDAV documents again, next time you return to create a link, you will have this problem again.

share|improve this answer
@hlhck thanks for your edit cause my language is Persian and i'm beginner – saber tabatabaee yazdi Oct 29 '12 at 8:18
absolutely if your SharePoint server has visitors with normal load , you have better speed to open them with explorer compared with Server that haven't any visitors unlike which we expected. beacause when server reserve resources to use sharepoint application in application start session is better performance compared with when application session being closed (has delay to start and then reserve and then prepare and etc.) – saber tabatabaee yazdi Oct 31 '12 at 5:18
This didn't work for me. – Peter Nore Feb 25 '14 at 16:27
what is your version of windows and office and sharepoint server? – saber tabatabaee yazdi Mar 1 '14 at 11:24
Office 2010, Windows 7, SharePoint 2010 – Peter Nore Mar 2 '14 at 10:52

In Internet Explorer, go to the Gear icon to Internet Options, to Connections to LAN Settings and make sure the box to auto detect proxy settings is not checked.

share|improve this answer

I finally found the answer. Save and reboot. Works like a charm every time. What a relief!!!

share|improve this answer
Please don't post a thank you comment as an answer. It will be deleted. Read tour and How to Ask if you want to know how this site works. – user 99572 is fine Mar 24 at 8:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.