Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a server where I host my VPN (Windows Server 2008 R2) and I can access all the websites that are hosted on the same server, but any time I try and make an internet request, the connection fails.

The Client is Mac OS X 10.8.1 with the Send all traffic box checked.

I also tried to connect with a PC (Windows 7) and another PC (Windows 8 RC) but neither of them could connect to the internet, but again, hosted websites worked fine.

As far as I can tell, its not a DNS issue, because DNS resolves fine when nslookup or dig are run. (See edit)

I even tried accessing http://208.69.38.205/ (The OpenDNS rescue page) and that wont load.

On the server, the VPN is setup with Network Policy and Access >> Routing and Remote Services and a custom configuration of VPN only.

I really dont want a split-tunnel type connection.

Bottom Line: Is there any way to resolve this and/or did I setup the VPN server wrong.

--EDIT--

I was wrong. DNS does not resolve unless the server is the acting DNS Server.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

I was able to solve the issue by crating a NAT interface.

Steps to solve. Assumes that Routing and Remote services (RaRS) has been setup with a custom configuration of VPN ONLY

  1. Open RaRS

  2. Open IPv4 (or IPv6 if you use it)

  3. Right click on General

  4. New routing protocol

  5. Select NAT

  6. Click OK

  7. Under IPv4/6 open NAT

  8. At the toolbar at the top, select Action -> New Interface...

  9. Select the Connection that connects to the internet, NOT INTERNAL

  10. Change the Interface Type to Public interface connected to the Internet

  11. Check Enable NAT on this interface

  12. Apply -> OK

  13. Connect with a client computer and test it out.

I recommend testing by going to google, and typing whats my ip if the ip is of the server, it works!

This question had only been up for a few minutes, but I have been trying to get this to work for days. I just hope that this can help somebody else.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.