Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Google Chrome version 21.0.1180.89 m (on Windows 7).

The problem is that I installed an anti-virus program that accidentally changed the home page (I didn't uncheck the option). Now every time I open a new tab, it goes to the web search of the anti-virus package.

My question is, how can I restore it to the thumbnails with most visited and a tab with apps and all the other stuff?

share|improve this question
    
Is this AVG? Please confirm what anti virus are you using. –  Dave Rook Aug 31 '12 at 7:33
    
-1 Use Google! reset new tab page chrome or reset homepage chrome –  tumchaaditya Aug 31 '12 at 11:17
    
It is Avira, and i googled already, but mayby not with the right words ;) –  Mathlight Aug 31 '12 at 11:29
    
i've found the solution :D –  Mathlight Aug 31 '12 at 11:53
    
please use the answers section for posting an answer, don't edit it into a question. If you can't post now, please come back & post later, I'll delete mine. –  Sathya Aug 31 '12 at 12:04
show 1 more comment

9 Answers

up vote 7 down vote accepted

After an second attempt and failing on it, i've found the solution. It isn't that hard to do.

First you have to determine the id of the extension that has changed the new tab. You do that to go to the extensions -> then go in development mode -> and then you see the ID's.

After that, go to the chrome default folder (C:\Users\user-name\AppData\Local\Google\Chrome\User Data\Default ) and copy (for backup) the file Preferences

Now close chrome, and open the file Preferences in any texteditor.

Search the file for something like this:

"chrome_url_overrides": {
         "newtab": [ "chrome-extension://aaaangaohdajkgeopjhpbnlpkehbhmbj/config/skin/new-tab.html" ]
      }

NOTE! the ID is probably difrent, but it has to be something like this : chrome-extension://ID_OF_EXTENSION/.....

Now look further down for "settings" and then the id of your extension.

There will be again somekind of this line:

"chrome_url_overrides": {
                  "newtab": "config/skin/new-tab.html"
               },

Delete that one to.

Save the file and start chrome and it will be fixed.

share|improve this answer
    
Note: Some plugins (like the one piggy-backed on Deamon Tools Lite) keeps resetting this parameter, so you must also make sure you uninstall the extension and quit Chrome before performing this operation. –  Nilzor Jan 26 '13 at 12:37
    
TWCrap, one can also: identify the name of the app in the preferences file under that same section you pointed out, and disable the app via chrome... –  user197480 Feb 11 '13 at 23:14
    
Obviously! best solution simply remove the crapware extension that was installed without my concent :) –  John Sep 9 '13 at 15:53
add comment

self answer by OP

Answer:

The problem with this is that you have to reset the default settings of chrome. This can you do verry simple, with the following steps:

The file path: Users --> Your User Folder --> AppData (this might be a hidden folder if you aren't admin) --> Local --> Google --> Chrome --> Default

The folder "Default" contains all of the requisite settings. To reset Chrome, close it and change the folder name of "Default" to anything else... "Default old" or "Default broken" or whatever else you like. Once you reopen Chrome it will be reset!

If you want to retain some settings (especially things like bookmarks and login info) you can copy (don't just move them because they should be kept intact as backups; copy them) those files into your new Default folder any time that Chrome is closed.

When you've done that, the problem is solved (depends on what you copy back or not, because you mayby copy the wrong settings back, but you will find out soon enought).

Hope this helps somebody else in the future also.

Source: http://productforums.google.com/forum/#!topic/chrome/xbmkn0Ohoh4

(post of Azzmo)

share|improve this answer
add comment

This worked well for me. Type into the address bar:

chrome://flags/

Then select "Reset all to default"

Hope it helps, Patrick

share|improve this answer
    
You just saved my life. I've uninstalled all programs installed today, disabled all chrome extensions, checked all chrome plugins - but nothing worked. "Reseting all to default" worked! –  psycho brm Aug 16 '13 at 13:41
    
You are very welcome. Very annoying when the browser gets hijacked so glad to help :) –  Patrick Sep 28 '13 at 6:49
add comment

Go to the wrench (in the top right corner) > select settings > select extensions (in the top left) > uninstall the extension of the AV program.

Another way is if you have an icon (of the av add-on) in the top right > right click on it > remove from Chrome.

share|improve this answer
    
The problem is that the web protection doesn't work then anymore :S –  Mathlight Aug 31 '12 at 11:29
    
Well then check for leftovers... Uninstall anything associated with it from add/remove programs or download uninstaller program which will trace registry and stuff and will delete them for you. After that your browser should be free of this. –  Magnum Aug 31 '12 at 12:26
    
I already tryed that before, but it needs the toolbar to function right. SO now i unistalled it on chrome, and left it over at ie and ff :D –  Mathlight Aug 31 '12 at 12:30
add comment

Sounds like an install only option, I doubt it's enforcing your homepage choice via the anti-virus program.

Click the spanner in top right hand corner. Choose settings.

In the "On Start Up" section, you will see the text "Open a specific page or set of pages". Click "Set pages" next to this, if you remove all the pages from here it will open a blank tab with your most visited/favourites instead.

share|improve this answer
    
sounds true, but when i start up, i want to contineu the session i quited before, so that doesn't work :S –  Mathlight Aug 31 '12 at 11:31
add comment

If its avg, click the new tab. It will open with the Avg search engine. on top right corner there will be an option to reset the toolbar. click on that and you can disable the search engine on new tab.

If another application, type chrome://plugins you will get a list of plugins. Disable the desired plugin.

share|improve this answer
add comment

If the start up doesn't want to change back its probably an extension, try going to program files and finding the folder which is name the same as the page/search engine you startup with (for example www1.delta..... you'd find the folder named delta). Go in and double click uninstall and watch it come back to normal

share|improve this answer
add comment

I use X new tab page on chrome and have had this same problem, where every so often (usually when I shut down/restart my computer instead of hibernating it) the page will crash. Then, when I open chrome, the home page is still the X new tab page, but when I open a new tab page, it defaults to the a different chrome one. This has happened twice, and both times, I have fixed it by un-installing the X new tab page extension and reinstalling it. So that you don't have to re-do all of your saved settings, be sure to do an autobackup of your x new tab page BEFORE you uninstall, then when you re-install, just log back in, and all your settings are saved! Hope this helps someone!

share|improve this answer
    
It's not answer the question –  hvtuananh Apr 25 '13 at 0:33
add comment

Why so complicated? Go to Chrome "settings", and then to where it says "Set which search engine is used when searching from the omnibox" and "manage search engines".

You need to restart Chrome for changes to take effect.

share|improve this answer
add comment

protected by Community May 29 '13 at 4:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.