Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Question is in the title, I had some friends visit and attach their PC's to my network. Ever since then, even long after the PC's were no longer attached, I am still getting entries for their PC's showing up in my Network folder of Windows Explorer, even after I refresh the view. How can I clear these out?


Answer notes: To aid the search of others later, it turns out that the second half of harrymc's answer was the correct part. I went in to my router (THOMSON TG585v7) firmware and found a list of computers under Home > Home Network > Devices screen. Hitting Configure on this screen let me delete old computers off the list and as soon as I did that, they no longer showed up in the Network folder.

share|improve this question

4 Answers 4

up vote 2 down vote accepted

Another thing to try is clearing the DNS cache:
Open the command prompt in administrator mode and type ipconfig /flushdns and reboot.

If it's your router that remembers these ghosts, it might have a configuration screen that will let you get rid of them· Otherwise, reloading factory settings might do it, but which I caution against. You might try to reboot your router if haven't done so already, then reboot your computer.

If all else fails, the ghosts will not stay there forever. Just wait thru the timeout period, which might be something like 30-60 days.

share|improve this answer

You should be able to just right click on the entry in the Network view and pick Delete.

share|improve this answer
1  
There is no Delete option on the computers in network view. Only Open, Open in New Window, Connect with Remote Desktop and Create Shortcut. –  Nidonocu Sep 25 '09 at 16:36

This may not work, but it's worth a go until someone with more knowledge comes along: Go into the Network and Sharing Center, and click Change advanced sharing settings. From there, drop down Home or Work (assuming that's what you're using), and then change the Network discovery option to off. Save the changes and then have a look to see if those computers disappeared. Make sure to hit refresh or F5. If they did go away, you could probably turn network discovery back on. Like I said, it may not work, so don't get mad at me... ;)

share|improve this answer
    
Nope, all still there. :/ –  Nidonocu Sep 25 '09 at 18:11

I had the same problem with Windows 7. To remove the old network computer names, you will need to re-register the DNS names.

Open a Command Prompt and type:

ipconfig /registerdns
share|improve this answer

protected by Diago Dec 21 '10 at 17:55

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.