Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have set a number of configurations in my .bashrc file to set the appearance of shell on my Redhat machine. However, when I login as root using Putty, the colours are not shown.

I can enable them again by typing 'su', which simply puts me back to root like I was when I logged into putty, but that isn't exaclty ideal.

Is there some configuration file or something I can use to enable shell colours when I login with Putty?


share|improve this question

migrated from Aug 31 '12 at 15:38

This question came from our site for professional and enthusiast programmers.

Try adding the commands to .bash_profile, which is run at login. – stark Aug 31 '12 at 11:43
Hero @stark you were right! Thank you – Jon Aug 31 '12 at 11:51

Adding the commands to .bash_profile seemed to do the trick, thanks @stark. I thought I tried that but after copying the contents of .bashrc the colours appeared on login =)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.