Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to configure an older switch that is only configurable via a Web GUI. The Web GUI only works in IE, too.

OK, so I am using IE 10 (in IE compatibility mode), and there is one particular popup window that refuses to load. For whatever reason, IE is trying to reach http://microsofttranslator.com, perhaps there's some content in the Window that is fooling IE into trying to translate it:

Silly IE translation

I'm doing all of this on a network that has no outbound access, so the window never loads.

If I load this Window in Google Chrome, the Window's DOM loads fine (though I can't use the Window because the Web GUI's JavaScript is IE-specific), so I am fairly certain this is being done by Internet Explorer itself.

How can I disable this automatic translation behavior in IE?

share|improve this question
    
It looks like the switch actually has code. The best you can do is modify the hosts file so that microsofttranslator.com is redirected towards 127.0.0.1. You must understand this is NOT a IE10 issue. The Web GUI has the code for the microsofttranslator.com widget this is 100% the fault of the software on the switch itself. –  Ramhound Aug 31 '12 at 16:50
    
@Ramhound I disagree. I believe IE is doing this, similar how Google Chrome will show things in Google Translate if it detects content in a foreign language. I looked at source of the HTML and wasn't able to find that. I also tried loading the window in Chrome (even though the JavaScript doesn't work), and it didn't try to reach microsofttranslator.com. At least the DOM was able to load. It would also be insanely stupid of Cisco to put translation code in their Web GUI. –  vcsjones Aug 31 '12 at 17:16
1  
Neither IE9 nor IE10 have a built-in translation which is the reason I thought it was software on the device itself. –  Ramhound Aug 31 '12 at 17:40

1 Answer 1

up vote 2 down vote accepted

Here is how you solve the problem:

  • Click the Tools button, and then click Manage Add-ons.
  • In Manage Add-ons, under Add-on Types, click Accelerators to display a list of your current Accelerators.
  • Click “Translate with Bing” from the list and here you can Click the Disable or Remove the accelerator.
share|improve this answer
    
"Does this solves the issue?" Yes. I had never thought to check Add Ins or things link that since this was a bare Windows 8 install. It seems that it got installed somehow, or came pre-installed. –  vcsjones Aug 31 '12 at 17:27

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.