Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to run a webpage outside of my local network using apache on Ubuntu 10.04. My webpage currently loads within my local network, so I know it's working, but it does not work outside of the local network. It is possible that port 80 is being blocked by my ISP or a firewall but I am not sure. Here are a few different errors I get while testing port 80:

80 HTTP Stealth There is NO EVIDENCE WHATSOEVER that a port (or even any computer) exists at this IP address!

Error: I could not see your service on XX.XXX.XXX.XXX on port (80) Reason: Connection timed out

80 (http) Closed or Filtered

My ISP is Cox Communications. My box running Ubuntu is wired and my laptop is connected to the local network wirelessly on a Linksys WRT54G2 router. Like I said, my laptop will pull up the webpage when apache is running but the webpage will not work outside the local network.

The issue must be with port 80. My question is what is going on with port 80, and how can I fix it (workarounds, firewalls, contact ISP etc..) so that I can get my webpage up and running?

share|improve this question

migrated from serverfault.com Aug 31 '12 at 18:49

This question came from our site for professional system and network administrators.

add comment

3 Answers

If you have your port forwarding configured and the difficulties still persists, then you may be facing a situation of the ISP blocking incoming port 80. Blocking incoming port 80 is a common practice with a lot of high speed cable operators when it comes to their residential service offerings.

share|improve this answer
add comment

You will need to configure your router to forward port 80 to your Ubuntu box.

share|improve this answer
    
In my port range forwarding configuration: apache 80 to 80 Both (TCP and UDP) 192.168.1.104 Enabled –  Stroiker Aug 27 '11 at 18:13
add comment

First verify that your port forwarding on your WRT54G2 is working correctly. Ensure that you can telnet (telnet $IP_ADDRESS 80) directly to your router's routable IP address on port 80 from another computer that is outside of your LAN (you could use a proxy). Or even better, use a tool like httping which will make http-requests to your website.

Try using an alternative port for Apache like 8080 or 8081 to try to confirm that your ISP is blocking incoming traffic destined for port 80. As user48838 suggest, this is not at all unusual for an ISP to do, especially for users with residential accounts (which I suspect you probably have).

You will need to change either the Listen directive or your specific virtual host configuration depending on how you set up Apache. See the manual for more information. You can confirm that Apache is running on a different port using netstat -at.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.