Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I installed ubuntu server 12.04 on a linode server. Every time i execute some command not found, it raise a error like this:

Sorry, command-not-found has crashed! Please file a bug report at:
https://bugs.launchpad.net/command-not-found/+filebug
Please include the following information with the report:

command-not-found version: 0.2.44

I tried to search for answers but didn't find a solution. It's there any method to remove this verbose error reports?

share|improve this question

migrated from stackoverflow.com Aug 31 '12 at 19:52

This question came from our site for professional and enthusiast programmers.

    
Are all packages at their current version? command-not-found is a application that suggests the correct command to run or package to install when you have a typo in your command line or try to execute an application that is not installed. –  knittl Aug 31 '12 at 14:15
    
Yes, all packages are at their current version. –  Ikbear Aug 31 '12 at 23:51
1  
Based on your comment below, it seems that you actually want command-not-found to suggest packages for you, and you do not want it to crash, but you don't want to remove it (since then it won't be able to suggest packages). If this is true, you may wish to edit your question. Reference: What is the XY problem? –  Michael Hampton Sep 8 '12 at 23:45
add comment

1 Answer

See HOW TO DISABLE COMMAND-NOT-FOUND IN UBUNTU;

either add the following line to your ~/.bashrc:

unset command_not_found_handle

or remove it by:

sudo apt-get remove command-not-found command-not-found-data
share|improve this answer
    
It works. But when i type a command which is not installed on the machine, Ubuntu should suggest me install related packages. But it's not. –  Ikbear Aug 31 '12 at 23:54
    
@Ikbear you can try to reinstall the packages using sudo apt-get install command-not-found command-not-found-data after removing them. –  Wimmel Sep 1 '12 at 0:12
    
The 'unset command_not_found_handle' option is the way to go here, IMHO. Thank you for this. It was really frustrating to make a typo and then have to wait for it to try and look up a package. –  Caffeine Coma Mar 12 at 12:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.