Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to force my Google Chrome web browser (version 21.0.1180.89, 64-bit) to use non-localized search (thus Google in English) through address bar, using the default Google search engine.

To achieve that, I have to change value of the property last_known_google_url to in Local State file (for instance on Linux, the full path to the file is ~/.config/google-chrome/Local State).

In that file, there should be the property:

"browser": {

but it is not.

Even if I add the property there, it has no impact on search—Google Chrome does not use the property and still searches in localized version.

Another option is to put the property to Preferences file (for instance on Linux, the full path to the file is ~/.config/google-chrome/Default/Preferences) - which works perfectly when I start Google Chrome and do some search - but just after that, the property (actually the whole Preferences file) is overriden, so "the most important" trailing part ?hl=en& of the property value is removed—and without it, the non-localized search does not work anymore.

Why does Google Chrome ignore last_known_google_url property in Local State file?

share|improve this question
The property in Preferences file is not overriden, when I put there something else than .com suffix. For example, if I put there value - it is not overriden - but again, it is not what I exactly want, because google behaves again little bit different than with .com suffix (for example, google sometimes finds fewer results; there is no "enter query by voice" feature; and little other differences). – Peter Sivák Sep 2 '12 at 14:19
have you tried adding as Default search engine from Chrome Interface ? – Ankit Mishra Sep 7 '12 at 15:36
Yes, but the problem is, that the instant search does not work with a custom search engine - therefore I am trying to change the default search engine. – Peter Sivák Sep 10 '12 at 20:36

4 Answers 4

You can simply add as your default search engine by using the chrome settings page (no tweaking needed). This will enable you to use non-localized search through address bar.

Steps to add new search engine:

  • Type chrome://chrome/settings/searchEngines in omnibox (i.e. the search bar)
  • Scroll to the bottom of the dialog and fill out the fields to set up the search engine.
    • Enter a label for the search engine.
    • Keyword : Enter the text shortcut you want to use for the search engine.
    • URL : Enter the web address for the search engine.

Detailed Instructions here.

share|improve this answer
It works, but the problem is, that the instant search does not work with a custom search engine - therefore I am trying to change the default search engine. – Peter Sivák Sep 10 '12 at 20:34
hmmm, the problem is bigger than I thought :) – Ankit Mishra Sep 10 '12 at 20:38

Google Search selects the localized version based on a few factors such as your geographical location (IP address) as well as your Google search preferences. Google Chrome settings actually does not impact which localized version of Google Search.

You can change it by going to (you should be redirected to the localized version), and click on at the bottom right corner of the webpage. You should see the non-localized version in future searches.

Another alternative is to use the url (ncr = no country redirect), which will redirect you to

Finally, selecting the display language as well as search result to English will also get Google to return international results.

Google Search settings for Language

share|improve this answer
I wanted to use non-localized search through address bar and none of your solutions helped me. Meanwhile, I have got used to search directly from website so I do not need to search through address bar anymore. – Peter Sivák Jan 5 '13 at 13:48
You can change the default search through address bar by customizing the search engine: Go to Options > Basic > Default Search > Manage.. Click on the default search engine and change the URL to – hanxue Jan 5 '13 at 14:27
Lol, I will write here the same response I have written 2 times so far in this topic in comments - the problem is, that the instant search (which I certainly want to use) does not work with a custom search engine - therefore I am trying to change the default search engine. But I appreciate your help. – Peter Sivák Jan 6 '13 at 18:37

After you set the 'last_known_google_url' as administrator, save the file and make it Read Only by right-clicking it and choosing Properties. When the file is Read Only, Chrome cannot "override" or ignore your settings.

By the way, in the new Chrome versions it's no longer Local State file, it's Preferences file located in: %localappdata% > Google\Chrome\User Data\Default

share|improve this answer
Please edit your answer instead of commenting on. – Shimmy Aug 20 at 3:43
intelligent-beyond-this-life: It would appear that you have accidentally created two accounts.  You should use the contact form and select “I need to merge user profiles” to have your accounts merged.  In order to merge them, you will need to provide links to the two accounts.  For your information, these are and  You’ll then be able to edit and/or delete your answer. – G-Man Aug 20 at 18:44
P.S. If you plan on being a member of the Stack Exchange community, I suggest that you register your merged account. – G-Man Aug 20 at 18:44

For an alternative workaround to your issue please follow this method:

  1. Download & Install 'editthiscookie' from:

  2. Link to

  3. Commit search via address bar

  4. Click on 'Editthiscookie' (cookie icon)

  5. Expand | PREF

  6. Click on the 'lock icon'(left side) to lock this cookie.

-From now on the chrome's default search engine will be Even if you delete your browser's cookies the 'default search engine' cookie will not be deleted.

*Please note that if you delete Chrome's cookies from a 3rd party software the protected cookie will be deleted as well.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.