Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When ever I type a wrong URL in to my URL bar, it redirects me to: www.website-unavailable.com

How do I stop this from happening? I would much rather just get redirected to Google.

This happens in both Chrome and Firefox.

I haved tried Spybot, Malware Bytes, and Windows Defender. None of which fixed the problem.

share|improve this question

5 Answers 5

up vote 6 down vote accepted

I'm betting that your DNS is probably set to the DNS servers of OpenDNS.

You shouldn't worry. If the above is true, your Web traffic is not being intercepted.

What's happening when you type a wrong URL is that, instead of the DNS server returning a response called "NXDOMAIN" meaning the website doesn't exist, the DNS server is returning a response with an OpenDNS IP, giving the OpenDNS system a chance to display a friendly message in your browser (and also show some ads).

Your ISP typically provides one or more DNS servers to resolve DNS queries. You don't have to use the ones provided by your ISP - you can use a third party DNS service and OpenDNS is one of those.

Under Windows, if you go to ncpa.cpl - then the network adapter of your Internet connection, right click, select Properties, then "Internet Protocol (TCP/IP)" and then click on the Properties button, this is where you can choose your DNS servers. If the "Obtain DNS server automatically" is checked - then your DNS configuration is being given to you by DHCP or otherwise used by the company. This may be the case in a corporate environment. You can override it manually if needed (in a corporate environment you probably can't do much on your end, though).

Some people find it is faster than their ISPs DNS servers. OpenDNS lets you add filtering options for your IP and a whole bunch of other services for organizations with multiple IPs - for example OpenDNS can refuse to resolve DNS queries to known malware sites.

Google also operates a public DNS service at 8.8.8.8 and 8.8.4.4 (and they follow the RFC saying they will return NXDOMAIN for invalid URLs - many, myself included, use them for this reason). Comodo operates one that is specifically meant to refuse to resolve known malwar sites. There's others out there, usually with some sort of filtering option that may appeal to you.

You can choose any DNS server you like to answer DNS queries for you. If you don't want to be redirected to a warning page upon entering an invalid URL, go back to your ISPs DNS servers (by ensuring the "Obtain DNS servers automatically" option is checked) or use Google. I believe you can also tell OpenDNS to stop doing this if you make an account from that IP and select appropriate options.

If you had your computer recently serviced, the tech may have set this for you in order to help you.

share|improve this answer
1  
To be unbelievably picky, opendns.com actually returns BOTH the IP address 67.215.65.132 AND an NXDOMAIN. (do "host to-be-picky.com" at the command line to get back "to-be-picky.com has address 67.215.65.132" followed by "Host to-be-picky.com not found: 3(NXDOMAIN)" –  barrycarter Sep 1 '12 at 5:35
    
Even after changing my DNS server its getting set back. –  Petah Sep 5 '12 at 8:41

It is your DNS provider. Either your ISP or whatever custom DNS server you choose to use.

See this question for information about finding a new DNS provider.

share|improve this answer
    
Even after changing my DNS server its getting set back. –  Petah Sep 5 '12 at 8:41

Try enabling Use a web service to help resolve navigation errors option in chrome

Steps to enable it:

  • Click the wrench icon on the browser toolbar. Select Settings.
  • Click Show advanced settings and find the "Privacy" section.
  • Deselect the "Use a web service to help resolve navigation errors" checkbox to disable the feature.
share|improve this answer
    
As it is happening in both Firefox and Chrome, it looks like it is the DNS server doing the redirecting. –  paradroid Aug 31 '12 at 22:21
    
oops,I missed the firefox over there. –  Lamb Aug 31 '12 at 22:24

I had a similar problem occur just a few minutes ago. Quite peeved about it actually. My new isp redirected any attempts I made to unreachable websites to it's advertisement laden page. What is worst it never even tells you that the website was unable to be resolved. Unforgiveable.

Anyway here is my solution.

Use a VPN service. It will encrypt your traffic so that your ISP doesn't know what you are doing. They will no longer redirect you when you visit unreachable websites.

share|improve this answer
    
The ISP was telstra bigpond. Just in case anyone was wondering. –  moomoochoo Jan 15 '13 at 13:16
    
You could probably just change your DNS server to 8.8.8.8 in your router. (Maybe...) –  daviewales May 20 at 12:28

Windows 7

  • Right-click on Network icon in taskbar
  • Select Open Network and Sharing Center
  • Select Change adapter settings
  • Right-click on the Local Area Connection
  • Select Properties
  • Select Internet Protocol Version 4
  • Select Properties
  • Select Obtain DNS Server Addresses Automatically
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.