Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In LibreOffice Writer, if I choose

Format -> Page... -> Background -> Background color

I can set a background color, but it is only used within the margins. How do I set the paper color? One way is to set the margins to zero, but that is not optimal, as I need the margins for the text.

Back ground color

share|improve this question
add comment

3 Answers 3

What do you want to achieve exactly? If you just want to modify the appearance of LibreOffice, without modifying the output, you could set a custom color for the document background: Menu "Tools" -> "Options" -> "Appearance" -> "Document Background".

If you want to modify the output, too, you will need to use a workaround, since you can only modify the area inside the page margins (as laurent described).

To modify the page appearance in a printable way, there's a nice workaround: Don't touch the page margins, but insert the content (full-page watermark, stationery, or just a full-page frame with a certain background) into the header / footer. This way, it will modify each new page, too. To modify the "background color" of the complete page, you could proceed as follows:

  1. Insert a header or footer, and put the cursor there;
  2. Select Menu "Insert" -> "Frame";
  3. Modify the frame properties:
    • on "Type" tab: frame size to paper size, bound to paragraph, Frame Position: "Entire page",
    • on "Wrap" tab: "Through"; Wrap Options: "In Background"
    • no borders,
    • background color as desired,

That's it - now you have a frame as "background object" on every page, thus effectively setting the page background.

See also the accepted answer in this ask.libreoffice.org thread.

share|improve this answer
add comment

A colored background will be printed and writer won't print anything inside the margins so it won't display anything inside the margins if you use the Edit -> Printer layout option.

If you disable Edit -> Printer Layout and set the background color, you will SEE the whole window colored on your screen but it won't print this way.

To print the full page colored without margins, I think your unique option is to set margins to 0. You can simulate the margins for text with the Format -> Paragraph -> Identation options after and before text.

Maybe a macro could do that but I think identation will be easier.

share|improve this answer
add comment

Please see this workaround, using a new Page Style: http://ask.libreoffice.org/en/question/7087/how-to-set-background-color-in-writer/

share|improve this answer
1  
Please refrain from providing link-only answers. They do not bring much use in the case when the link changes. –  edvinas.me Apr 20 at 21:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.