Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Just upgraded from VLC 1.05 to VLC 2.03 (latest).

Problem: Videos (.avi) get stuck on the first frame.

(These same videos used to play just fine in VLC 1.)

share|improve this question
    
Excellent example of a question/self answer. Thank you for taking the time to post it. –  Nifle Sep 1 '12 at 3:16

2 Answers 2

In addition to AKE's solution of changing the default demuxer, I have an alternative resolution.

I had an m4v format video which also was also stuck on the first frame.
The reason however was not the demuxer's fault per se, and not the root of the problem.

After playing the video with the "Avformat" demuxer, the audio was about 6 seconds behind the video.
The audio being more than 5 seconds behind results in the first video frame being stuck with the default demuxer..
Thus changing the demuxer would display past the first frame but not solve the sync problem.

Leaving the default demuxer alone, simply go to the menu:

Tools > Track Synchronization

On the Synchronization tab, lower the Audio Track Synchronization to the necessary value. The video should begin to play correctly once the audio is less than 5 seconds behind.

share|improve this answer
    
(+1) for good alternative resolution. Though this would likely not have applied to my situation (I had no audio since my video was created from a collection of images), it's a useful possibility to catalogue. Cheers! –  Assad Ebrahim Apr 29 '13 at 22:17
up vote 4 down vote accepted

Solution:

Note: a symptom of this problem is seeing debug messages picture is too late to be displayed. (To turn on debug messages in VLC, see the section at the bottom of this posting)

The problem appears to be a bug in the default demuxer.

The solution is to change the default demuxer to the Avformat demuxer.

Here's how:

Menu Tools -> Preferences >

... -> Click radio button to Show Settings = ALL instead of SIMPLE

... -> Input/Codecs > Demuxers >

at very bottom of drop down list:

... -> Avformat Demuxer > Save, exit and restart VLC

This should solve the problem.


Credit to Jean-Francois and Lotesdelere on the VideoLan forum. http://forum.videolan.org/viewtopic.php?f=14&t=98381&start=80 Unfortunately, their correct solution is buried at the bottom of 5 pages of responses that don't work... hopefully this archives the solution so that it is easier to find in future.


Turning on Debug Messages in VLC:

Go to: Tools > Messages > Increase verbosity from 0 to 2

Then play the video.

If there are problems, you should see error descriptions in the Message panel.

share|improve this answer
    
Thank you for the insight above. Any idea about similar issue with multicast udp streaming? Because the format is not avi, i start getting invalid format error though the debug messages are exactly same with automatic. I have already tried various video output modes. –  fayyazkl Feb 11 '13 at 12:36
    
@fayyazkl: Hm, UDP is not a format of its own, it is just a protocol for sending data between machines connected via a network. However, it defines maximum packet size, and (typically) does not check for dropped packets or packets out of order (TCP does). You might start by checking what underlying video format is being streaming, and then doing some google'ing to find out how VLC handles UDP streams. Good luck! –  Assad Ebrahim Feb 13 '13 at 8:22
    
Thank you AKE, I understand UDP pretty well and under lying stream is from live tv. Point is that standard vlc release 2.0.5 runs it fine but not with my cross compiled version on a few specific machines. –  fayyazkl Feb 13 '13 at 11:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.