Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using HP ProBook 4520s and have ATI Mobility Radeon whose graphics card doesn't support Ubuntu. Infact, it produces more heat and consumes a lot of battery which causes system usually hangs.

I read somewhere that disabling my discrete graphics card can solve problem. I am not a gamer but a web application developer, hence I think those HD graphics are not neccessary for me. Integrated graphics will be enough for me.

I tried disabling it from BIOS but didn't see any option there to disable it. So can someone please help me to disable discrete graphics card either from BIOS or Ubuntu? It will help my system running smoothly!

Thanks..

share|improve this question
add comment

1 Answer

Actually, the BIOS won't carry an option to disable it.
But, it may carry a setting wherein you provide GPU preference sequence(similar to boot device sequence). Just push down the discrete GPU below onboard one and you will be good to go.

2 things:

  1. Your motherboard must have Intel HD graphics. Not all boards have it.
  2. The setting is available only with some boards, not all.

I can suggest 2 alternate ways:

  1. Find good ubuntu drivers for your card(I am pretty sure there would be some; Have a look at this: http://www.linlap.com/wiki/hp+probook+4520s and this https://help.ubuntu.com/community/BinaryDriverHowto/ATI)
  2. Physically take out the discrete card(I don't recommend this though)
share|improve this answer
    
I tried the driver from hp site but that didn't work, actually hp recommends and provide driver for opensuse. –  Hafiz Sep 3 '12 at 12:50
    
HP wont go and provide drivers for every linux distro out there... Try the radeondriver from here:help.ubuntu.com/community/RadeonDriver or the fglrx drivers provided in answer –  tumchaaditya Sep 4 '12 at 12:44
    
My problem isn't yet solved but giving bounty point because your answer helped me to understand things. thanks –  Hafiz Sep 9 '12 at 18:39
    
wel...you should not award the bounty if your problem is not solved... have you tried the 2 drivers mentioned above? –  tumchaaditya Sep 10 '12 at 3:31
    
I tried but didn't solved the problem, seems like problem is not of driver but GPU seems to need to power in to work properly (I found this from one of above links) and if this is so then I don't think if there will be other solution. If I always plugin my system then there is no problem. –  Hafiz Sep 10 '12 at 6:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.