Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

There have been other threads on this but none of the solutions mentioned have helped me.

Spotlight has stopped showing any results for my Applications.

  • I've tried reindexing and removing the index so it rebuilds it. No change.
  • I've tried adding Applications to the Privacy tab and removing it, no change.
  • I tried repairing disk permissions and redoing the above, no change.
  • I've tried removing everything from the index except Applications and then I just get nothing for any search at all (except dictionary entries).
  • I tried adding a symlink in my homedir to Applications and reindexing, but no change.

Any ideas on what to do? I'm running Snow Leopard. This is driving me crazy!

Update: I've noticed that when I start a reindex with sudo mdutil -E / and then immediately do a spotlight search for an app that the app shows up temporarily until spotlight gets disabled due to active indexing. After the indexing is done the app entries go away.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

After much more experimentation I hit on something that fixed the problem. I went through the Applications directory looking for anything that didn't belong, and removing any and all cruft. I didn't find anything blatantly out of place, but there were a number of files, directories, PDFs, etc. that had gotten stuck in there over the last couple years. I removed it all, rebuilt the index with sudo mdutil -E / and it is now working perfectly. In fact it's faster than I can ever recall.

Hope this helps someone else.

(p.s. I wasn't sure if answering my own question was the right way to do this. If it's not, please let me know.)

share|improve this answer
    
It is indeed the right way to do this. Cheers :) –  JoshP Sep 19 '12 at 13:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.