Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a bit of a newb at web stuff. Have got a website I bought a few months ago hosted by Hawkhost (www.modernfurnitureart.com). All has been going well, but about a week ago I was suddenly unable to access it or my wp-admin from my home Mac (imac 2.7 GHz Intel Core i5 running OS X 10.8.1) .

However, I am able to access it from work, which uses the same ISP & from my phone and also, more importantly, on my iPad which is connected by wifi on the same home network.

Whenever I try to access it on the mac (in any browser) I get a cpanel default web page message saying that the IP address may have changed, there may have been a server misconfiguration or the site may have moved to a different server. None of this seems to have occurred as I can access it elsewhere.

I have flushed the DNS cache by using the dscacheutil -flushcache command in the Terminal, and then when I realised that there is a newer command for doing this in Mountain Lion, with the sudo killall -HUP mDNSResponder command.

I have restarted my computer, but with no results.

share|improve this question
    
Can you access it via it's IP? 50.23.102.67, but if you get cpanel I think you have to contact your hosting custumer support. –  Nifle Sep 3 '12 at 7:52
    
Have you tried clearing browser cookies and cache? –  slhck Sep 3 '12 at 7:55
add comment

1 Answer

up vote 3 down vote accepted

What do you get when you try ping www.modernfurnitureart.com from a terminal window? If it's not 50.23.102.67, then there is indeed a DNS problem.

Is it possible you have an entry for your site in your /etc/hosts file that is pointing to the wrong IP address? See this page for details on how to check if you don't know how.

share|improve this answer
    
Hi there, thanks for the responses. Sorry for the delay in getting back. Embarrassingly, I forgot where I'd posted this request to, and had to go searching to find superuser. Jeff, you were right, my /etc/hosts/ file was pointing to the wrong IP address, which is really weird, because I've not been near the /ect/hosts file. Have fixed this and I can now get my website up if I type in www.modernfurnitureart.com, but not if I just type in modernfurnitureart.com (without the www). This is despite the /etc file reading: 50.23.102.67 modernfurnitureart.com www.modernfurnitureart.com. Any thoughts? –  Jonathan Cohen Sep 12 '12 at 8:50
    
Jonathan, there should be no need to have any entry in your /etc/hosts file at all. You should remove that line completely and rely solely on DNS to resolve your website name. My guess is that at some point you did actually edit your /etc/hosts file...maybe when you were first developing your site someone told you to add an entry because the DNS wasn't set up or propagated yet. There is malware that will modify /etc/hosts, but I can't imagine it would make this type of change. –  Jeff Olson Sep 12 '12 at 14:22
    
Hmmm...you're right. That worked. I may have had to change something in the /etc/hosts file at the beginning, though I don't recall it - it was four or five months ago. Anyway, a big thanks for resolving this for me. Very much appreciated. –  Jonathan Cohen Sep 13 '12 at 0:09
    
You're welcome. Since you're new, I will point out that proper StackExchange protocol would be to now accept my answer as the correct one. :) –  Jeff Olson Sep 13 '12 at 4:06
    
...Accepted! :) –  Jonathan Cohen Sep 13 '12 at 21:42
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.