Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I cannot delete a folder located on my hard disk by any means.

I don't quite know how it was created, all I know is, that it is a pretty deep structure of folders (too deep to delete it at once, since Windows restriction path name too long), but the problem in the end is, that I can't "pull out" the inner folders, because they don't seem to be folders anymore (Context menu lacks things like "Properties", "Cut", "Copy", "Delete" etc.)

Here a picture of how a right click looks like on one of these "folders":


As you can see, the current folder is in very deep, but that is not the problem, rather the one I left-clicked on.

Has anyone any advice on how to get rid of these?

I tried a chkdsk, said no errors. I also tried deleting those folder via a VMWare Ubuntu, to no success. I also tried a batch file from a volunteer at MS boards, that should automatically de-nest such folders, but I guess mine is a special case, since the tool only created more such folders.

share|improve this question
Welcome to SuperUser, I edited your post, if you don't like the changes feel free to edit it again or revert them. – Baarn Sep 3 '12 at 8:12
Can you confirm that your menu when you right click (as pictured) only happens in these deep folders - if you right click on a folder on your desktop to you get the Copy/Cut/Property options? – Dave Sep 3 '12 at 8:15
@amotzg, Correct me if I'm wrong but, sfc looks and repairs an entirely different scope of things. ie. Not broken/chained/nested folders. – DM8 Sep 3 '12 at 8:57
It seems you already have Ubuntu disc. Boot into Ubuntu Live CD and try deleting the folder from there. P.S.: Can you share the batch file you tried to use? – tumchaaditya Sep 3 '12 at 10:53
sfc stands for system file has nothing to do with other files/folders.. – tumchaaditya Sep 3 '12 at 10:54
up vote 4 down vote accepted

Maybe some files inside the folder, (or deep inside the subfolders in it) are locked by windows because they may be in use by another programs / processes.

When that happened to me, i used a program named "unlocker", that, as name implies, unlocks files in use and let you delete them (and thus, delete the entire folder structure).

Note that maybe windows or your AV program may detect it as a virus, so use it at your own risk. Though, i've used it several times (at least back in the windowx XP days) and never had a problem.

Another option is trying to delete the files/folders in windows "safe mode" (hit F8 when rebooting your computer to enter that mode. You can even try "unlicker" within safe mode and see what happens (im not sure).

And if those two options fail, then you may simply have a virus.

BTW, i doubt the folder "depth" itself is the cause of the problem, but more likely, the "effect" of have a virus.

Still, could you give us the full path here? It is suspicious that you have so much "application data" nested folders.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .