Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a mysterious volume mounted on my desktop that I can't seem to forcibly unmount. I've tried using umount and also diskutil, but it seems to automatically remount itself. I've copied my hdd with Time Machine, and copied it onto a new computer, and it also has the drive mounted on it. It's not pointing to anything and I can't open it, nor can I forcibily remove it by hand with rm -Rf.

Any ideas? I noticed this problem after I upgraded to Mountain Lion from Lion. It causes problems because when I try to select a file using the built in Finder dialog box, it freezes for a few minutes because it tries to cache or read into the "media" mounted volume.

Picture of my desktop

I added a picture so you guys can see what I'm talking about. It's a media volume that is mounted on my desktop, but I can't get it to go away and it really slows down my finder when I use it to select items.

share|improve this question
    
Can you post the output of the 'mount' command? –  Matteo Sep 3 '12 at 8:55
    
Type mount and the path of the folder? What command you want me to run? –  Allen Sep 3 '12 at 13:53
    
I tried running diskutil umount but it doesn't work: diskutil umount ./media Unmount successful for ./media But the volume is still there. –  Allen Sep 3 '12 at 14:06
1  
just "mount" without parameters. It should print the list of mounted volumes –  Matteo Sep 3 '12 at 14:58
    
Hmm, it actually showed up, but not sure what it means: map -static on /Users/allen/Desktop/media (autofs, automounted, nobrowse) –  Allen Sep 3 '12 at 22:35

2 Answers 2

up vote 1 down vote accepted

finally got that mofo deleted! Thanks much for your help, Matteo! If you would have put up an answer, I would have give you the credit. All because of the mount command telling me some info, I did some google search. I had to open up Directory Utility, and I went to mounts and found a mount in there. I deleted that record and bam! The folder appeared back on my system and I could delete it!

Here is a post that relates to mine: Permanently map a network drive on Mac OS X Leopard

share|improve this answer
  1. Open up terminal

  2. Type in diskutil list

This should give you a brief overview of your devices

Here you may find more information about your mystery device

  1. With it, there is a name. e.g Disk1, Disk7 etc. Note the one for your mystery device.

  2. Type in diskutil eject /dev/DiskX

X being the number asigned to the device you want to remove

share|improve this answer
    
I don't see anything like that. I just se a table like this: $ diskutil list /dev/disk0 #: TYPE NAME SIZE IDENTIFIER 0: GUID_partition_scheme *500.1 GB disk0 1: EFI 209.7 MB disk0s1 2: Apple_HFS Macintosh HD 419.0 GB disk0s2 3: Apple_Boot Recovery HD 650.0 MB disk0s3 4: Microsoft Basic Data BOOTCAMP 80.2 GB disk0s4 I just see /dev/disk0 –  Allen Sep 3 '12 at 14:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.