Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After I launch a virtual machine (Ubuntu 12.04) in headless mode on Windows 7 host

C:\Users\XXX>VBoxManage startvm "ubuntu 12.04" --type headless 
Waiting for VM "ubuntu 12.04" to power on... 
VM "ubuntu 12.04" has been successfully started.

Can I somehow launch the normal GUI that I would get by launching the virtual machine from VirtualBox' GUI ?

I know that I should be able to RDP to this machine but when I use Windows 7 built in RDP client and use localhost:rdp_port (forwarded by NAT in VB options) I get the error

    ---------------------------
    Remote Desktop Connection
    ---------------------------
    Your computer could not connect to another console session on the remote 
    computer because you already have a console session in progress.
    ---------------------------
    OK   Help   
    ---------------------------

What can I do in this situation to connect to this virtual machine with GUI ?

Is it the only solution for me to turn the machine off and then launch it with the GUI ? It sounds really not convenient to do this every time I need GUI - since I want the machine to be headless.

EDIT

I have also tried xrdp but I cannot connect to the machine - I have it behind the VirtualBox NAT and the ports are forwarded.

share|improve this question

I just solved this problem by clicking the green arrow "Show" at the top of the VirtualBox GUI while my headless instance was already running.

I could see what the VM window would look like inside the "Preview" Pane on the VirtualBox GUI, and after clicking "Show", the VM window came up as though I had initially powered on the machine from the Virtualbox GUI.

share|improve this answer

After getting the same error, I just changed the default port 3389 to something else.

I used random port number (in my case 5500). Then it worked.

And disabled Windows firewall for a moment - but I don't think firewall was the problem.

share|improve this answer
up vote 0 down vote accepted

I solved the problem - I didn't have VirtualBox extension pack installed. While it is added in Linux version of VirtualBox, you have to install it separately on Windows.

share|improve this answer
1  
But could you open the GUI of a Headless VM? – Fabricio PH May 24 '14 at 3:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .