Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Every time I turn on my PC, I get the following message:

Checking file system on E:
The type of the file systen is NTFS.
One of your disks need to be checked for consistency. You may cancel the disk check, but it is strongly recommended that you continue.
Windows will now check the disk.

CHKDSK is verifying files (stage 1 of 3)... 0 percent completed

I allow CHKDSK to to complete, but Windows does not load. This message appears every time I boot my computer.

Could someone explain me why this message appears and what I should do to make it disappear?

share|improve this question
    
possible duplicate of XP disk check runs every time I boot –  hims056 Mar 29 at 6:16
1  
@hims056 That question refers to a system that is working. The OP has stated that chkdsk completes but Windows does not load. –  Tog Mar 30 at 8:06

3 Answers 3

When you schedule a check disk, an entry is added to the registry - for some reason, it's not being cleared. I actually did this yesterday and it's very easy.

Run the Registry Editor(Regedt32.exe) (open click start, run and type regedit then press OK).
Under the HKEY_LOCAL_MACHINE subtree, go to the following subkey:
\SYSTEM\CurrentControlSet\Control\Session Manager
Change the BootExecute entry from:

autocheck autochk * /r\DosDevice\C:

To:

autocheck autochk *

Source http://support.microsoft.com/kb/158675

share|improve this answer
    
I go step by step in those article, but in my Registry Editor BootExecute already has value autocheck autochk * not like autochk * /r\DosDevice\C: –  khris Sep 3 '12 at 12:55
    
If the CHKDSK were scheduled, I believe the message would say that. This seems to be a problem with the HDD itself, rather than a scheduled disk check not being cleared. –  Indrek Sep 3 '12 at 13:38
    
Yes, it does. In that case, I would suggest checking it with acronis.co.uk/homecomputing/products/drive-monitor –  Dave Sep 4 '12 at 10:39

If you have not asked for a chkdsk to be carried out, the autocheck will be carried out if the disk dirty bit is set. This will be set if Windows is not shut down correctly, file changes have not completed or the disk is corrupted. It may indicate the disk is about to fail. For an external disk, it may indicate it was removed without using the 'safely remove hardware' function.

The fsutil command can be used to check the status of the dirty bit.

share|improve this answer
    
I check my hard disk, it is dirty - what should I do to correct this? –  khris Sep 3 '12 at 14:03
1  
Try running chkdsk /f e: or chkdsk /f /r e: manually. If the dirty bit is still set after the next reboot, the system probably cannot umount the volume on shutdown. Check the eventlog for pointers if that's the case –  Ansgar Wiechers Sep 3 '12 at 14:27
    
I get such message after executing command chkdsk /f e: E:\Documents and Settings\Consultant>chkdsk /f /r e: The type of the file system is NTFS. Cannot lock current drive. Chkdsk cannot run because the volume is in use by another process. Would you like to schedule this volume to be checked the next time the system restarts? (Y/N) n –  khris Sep 3 '12 at 14:42
1  
@khris That's normal. You can only run chkdsk on the system drive at boot. –  David Marshall Sep 3 '12 at 15:36
    
ok, I try once again: 1) enter chkd /f /r in cmd 2) press y after message that drive can't be locked 3)restart my pc - the same message (as in my parent question) 4) allowfile verifying. In result I get message thet verifying is complite on blue screen and windows do nnot load and I can't execute any command - just shut down os pressing button on keyboard. –  khris Sep 4 '12 at 7:22
  1. click on your start menu and open the run dialog.
  2. type "cmd" and return (note: dont enter quotes)
  3. Next type "fsutil dirty query e:"
  4. If the return message indicates that the volume is dirty go to step 5
  5. Next type "chkdsk e: /f /x"
  6. After that finshes repeat step 3.
  7. If it is no longer dirty then reboot and you should notice no more ckdisk.

Source of Information

.

share|improve this answer
    
it doesn't help - see earlier comments –  khris Sep 4 '12 at 7:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.