Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Dropbox won't let me choose the sync folder inside a NTFS partition. First thought I had was mounting and its permissions (the Dropbox installer does let me choose my linux home as the Dropbox home). After searching and trying several other lines, the partition is mounted via fstab with these settings:

/dev/sda5 /mnt/documents ntfs-3g uid=1000,gid=100,dmask=027,fmask=137 0 0

I can read and write in the partition, here is a ls output:

24 drwxr-x---  1 tuxcayc users 24576 Sep  2 06:42 documents

I'm using an Arch-based distro (Manjaro) and Dropbox installed via yaourt.

I guess it's still some issue with mounting permissions. Any help is appreciated,

Thanks.

share|improve this question
    
Have you tested to make sure you actually CAN write, not just that it claims you can? I don't know why it would claim you could when you couldn't, but it's worth checking. Also, are you able to use bind mounts to work around this? –  Daniel H Sep 4 '12 at 1:37
    
@DanielH I can actually write (delete, download files, etc) I don't know about binding mounts (?). The strange thing is in earlier Ubuntu-based and Arch-based distros there was no problem. –  Cristian Sep 4 '12 at 1:51
    
A bind mount is where you mount one folder on another (mount --bind olddir newdir). Except for "olddir" being a directory instead of a device, and the "--bind" flag, it works like any other mount. –  Daniel H Sep 4 '12 at 1:55
    
If you're using several file systems in several partitions on your system, there's a chance that Dropbox just cannot handle being run on one filesystem and syncing on another filesystem. Or even that it cannot be used correctly if it's not run from a partition of the same filesystem as the OS's and only affects that file system. That was my only uneducated guess. –  Ariane Aug 20 '13 at 17:56
    
tried to symlink from the ntfs partition? –  Lorenzo Von Matterhorn Sep 18 '13 at 18:51
show 1 more comment

2 Answers

Dropbox is using filesystem hooks to know what and when files have been changed. I would guess that NTFS mounting in Linux would not trigger these mechanisms as it would on native Linux file systems. I'd say nothing is wrong with your mounting, but Dropbox can not handle NTFS in Linux environment.

If you really need to sync to NTFS drive, you can either use rsync to copy your files to NTFS while you are in Linux. Or... use Dropbox for what it is supposed to be used: have a dropbox folder on linux drive and Dropbox folder in Windows. And one would sync with the other when you boot to Linux/Windows (I presume you have dual-boot).

share|improve this answer
add comment

I would go to the software manager and search "NTFS" I found a manager and ran it, that fix an issue I had with writing and having other programs make files. I could make the folders myself but I couldn't run things off of it or install things through other programs like steam until I ran NTFS configuration tool.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.