Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been running Windows Mail fine on my Windows Vista 64 computer for several years.

A few days ago, for no apparent reason, it began failing to stop its WinMail.exe process whenever I'd exit the program. I usually exit with the "X" at the top right of the window. The window would close but the WinMail.exe would keep running.

As a result, if I'd attempt to open Windows Mail again, it would not start up. If I go into Windows Task Manager. I would see two WinMail.exe processes. If I end both processes, then I could start Windows Mail. But again, closing it and the process would still remain running.

I searched the web for answers. Some indicated it may be antivirus email checking. I'm using Microsoft Security Essentials. I turned off real time protection, but the problem still happened.

Some answers indicated the database may be corrupt. I got a utility called WMUtil and I repaired and compressed the database, but that didn't solve it.

I even went back to a restore point of about a week ago, before the problem started. That didn't fix it.

I'm stumped and this is very annoying and frustrating. Does anyone know how to fix this?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I solved my problem. It was NOT what I expected, so I'm posting this answer to help others who may encounter this.

I found a post by a Michael A. Covington, who way back in 2008 had the same problem as me. What I noticed in his post was that he had a second problem as well, and I had the problem too -> Explorer hanging when deleting from the desktop. However none of the responses to his post were the correct solution.

I was going to try to find Mr. Covington and ask him if he found a solution. In my search for him, I found this post by him, stating he solved his problem.

The cause was that SearchIndexer.exe was holding fles open for some unknown reason.

The fix was to go to Control Panel, Administrative Tools, Sevices, and disable Windows Search. This just disables the search caching, but still allows searching.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.