Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Thinkpad T420 (4178-BSG) I use with Windows. The fan (cpu) was always very quiet and I was completely satisfied with it. A few days ago I booted Backtrack Linux from a flashdrive and the fan started to spin at maximum and was very loud. The problem is that this state persists. When I start the Thinkpad and boot Windows as usual the fan start spining at max and never stops. It drives me mad. It looks like somehow the Linux change some settings and I have to suffer. I tried reseting BIOS, updating BIOS, nothing helpes. I even removed the keyboard, looked at the fan but there is no dust.

Update Maybe there is a problem with the integrated Intel GMA 3000 Card. The Power Manager shows it at 100% at all times:

enter image description here

share|improve this question
1  
It sounds like Linux probably had nothing to do with it and it was just a coincidence. Did you remove the heat sink or loosen its screws at any time? –  David Schwartz Sep 4 '12 at 9:22
    
Check your CPU activity and temperature when you are in Windows. Maybe you installed something else in the same time frame which is making the CPU active all the time. –  Gnoupi Sep 4 '12 at 9:45
2  
Another test, leave the computer on a boot select screen for a moment (or in general, any place without a system launching, can even be the bios screen), and see if you have the problem. If yes, you have probably a hardware issue, like David is suggesting. –  Gnoupi Sep 4 '12 at 9:46
    
Also have a look at my answer here. –  terdon Sep 4 '12 at 10:34
    
I made no hardware or software changes. I have Windows 8 and Windows 7 dual booted. I booted Windows 7 after maybe 3 months and the problem is also there so I do not thnik it is a software problem. The fan runs at 3580 RPM even if the temperature is only 47C and the computer is idle. –  Igor Kulman Sep 4 '12 at 11:13

1 Answer 1

up vote 0 down vote accepted

I think it is likely that the Linux boot and/or the dual boot with Windows 8 somehow changed the motherboard settings for the fan control. I would proceed with:

  • Check the settings for fan control in the ThinkVantage Power Manager (use the Advanced view), see Advance Power settings. Check if the Linux OS changed essential settings for the predefined power agendas. Especially check the settings for what the computer does when idle.
  • Install and use tpfancontrol, see tpfancontrol. Maybe that
    program can help you to regain the control of the fan. I have used it on a number of Thinkpads, not a flashy interface but works very well. Since you have both W7 and W8, you should probably install it on both OS (tpfancontrol W8 - works
  • TP420 is usually sold with three years of warranty & service. Check your warranty - can be done through the ThinkVantage Toolbox.

Also, check out this question and its answer for getting the Linuxversion to work, Problem w t400 fan w linux

share|improve this answer
    
tpfancontrol works ok when I set it to smart mode. But it does seem to work under lockscreen on Windows 8, so when I lock the computer and get away from it for some time the fan spins full –  Igor Kulman Sep 4 '12 at 20:19
    
great that it works! it seems like the fan goes back to the BIOS mode when you lock the screen, will check my configs because that is not the case for my installations –  FredrikD Sep 5 '12 at 4:32
    
Checked my installation(s), they are all standard ones (I have adjusted the fan control though), didn't find anything that relates to the screensaver issue you raised. –  FredrikD Sep 6 '12 at 12:46
    
It so not screensacer, the display turns of after some time and then the fan starts spinning. I read rhe whole config and I do not think there is a way to change this behaviour. –  Igor Kulman Sep 6 '12 at 13:55
    
Hmm.. maybe it is a Powersetting issue. If you have the Thinkvantage Powermanager installed, you can change what the system does depending on activity –  FredrikD Sep 6 '12 at 14:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.