Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When trying to install SQL Management Studio express I'm met with the following error

Error

But I have version 4 of the .net framework installed, so this shouldn't be a problem?

I'm running MS Server 2008 R2

Any help would be greatly appreciated!

share|improve this question
1  
In Server 2008R2, the .Net Framework 3.5 should be installed through the Server Features (in the Server Manager). – Oliver Salzburg Sep 4 '12 at 11:30
up vote 1 down vote accepted

Newer versions of the .NET framework don't completely replace older ones. If a program specifically requires an older version, then you need to install that version. So do what the error message suggests.

You can get .NET 3.5 SP1 here:
http://www.microsoft.com/en-us/download/details.aspx?displaylang=en&id=22

share|improve this answer

.NET 4.0 is not a superset of .NET 3.5. If an application requires .NET 3.5 SP1 you must install .NET 3.5 SP1.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .