Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After I ssh to the mac desktop from linux Suse, I could not open matlab even without GUI. The mac desktop has mac OS 10.6. At the beginning, I thought the reason is that I did not use -X flag. However, after I tried "ssh -X remote", it still could not work. Also, Whatever I tried any option to open matlab like "matlab -nonjvm", "matlab -nodesktop" and so on, it always reported the same error message:

Mon Sep 3 16:00:41 java[74327] : kCGErrorFailure: Set a breakpoint @ CGErrorBreakpoint() to catch errors as they are logged. Could not open display. Exiting.

I really appreciated if anyone can answer my question. Many thanks.

share|improve this question

migrated from Sep 4 '12 at 11:20

This question came from our site for professional and enthusiast programmers.

Not sure, but you seem to have a problem with the Display variable. Try 'matlab -nodisplay' - this should turn off the display features. The '-nojvm' switch does not - you can still show figures on the display.

Also, try to inspect what the DISPLAY variable says after you ssh to your Mac (echo $DISPLAY).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.