Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to set up a website that is hosted on my computer. I'm using Win7 with IIS and an O2 Wireless Box II. I can access that website using http://localhost or http://192.168.1.104 (subnet ip address).

tbh, I feel like I'm guessing about how to do this but I am a software developer so do have some technical skills. I have set up port forwarding as the following link details how

http://www.o2help.co.uk/router-port-forwarding/ 

tbh, I'm not really sure how port forwarding works.

The only protocol option is TCP & UDP (create game or app link) so I have set port forwarding up as Protocol TCP & Port No 8080 (I also experimented with Port nos 80 & Port 7976).

Unfortunately when I navigate using a computer outside the network to http://myipaddress (I'm using the ip address of the O2_ADSL2plus connection), I get a 'the connection has timed out'. I am obviously missing something as it is not working.

What am I doing wrong? What URL should I use to find my site? Do I need to specify the port no in the url if I don't use port 80? Is it a problem I only have an option for the TCP protocol and not http? How does the subnet ip (192.168.1.104) relate to the external ip address? Is this possible using O2 broadband and my O2 router?

Thanks

New Application
  name:            FAL80
  How to define:   manual
  [next]

Port
  Protocol:          TCP
  Port Range:        80   80
  Translate to:      80   80
  Trigger Protocol:  -
  Trigger Port:      -
  [add]

Assign application
  Application:       FAL80
  Device:            my_pc
  [add]
share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

You need to forward an external port to the internal port of your webserver, these can be the same. By default, your webserver runs on port 80, so you need to forward port 80 to the internal IP-address of your computer.

New Application
  name:            my_webserver
  How to define:   manual
  [next]

Port
  Protocol:          TCP
  Port Range:        80    to:  80
  Translate to:      80
  Trigger Protocol:  Any
  Trigger Port:      (blank)
  [add]

Assign application
  Application:       my_webserver
  Device:            my_pc
  [add]

ISPs often block port 80 because their terms of service prohibit end-users running web-servers.

Some (most?) router will allow you to forward a high-numbered external port to a different numbered internal port (strictly this is Port Address Translation (PAT) but usually it is just part of the port-forwarding facility). SO you could forward external port 8080 (say) to internal port 80 at the internal IP-address of your computer.

If you configured the router to forward port 8080 to port 80 The URL you have to use from outside your own LAN would be something like http://123.45.67.89:8080/ where 123.45.67.89 would be replaced by the external IP-address of your router as shown by services such as WhatsMyIP.com.

If your ISP does not allocate a static IP-address to you, your IP-address will change from time to time. You can register with a dynamic DNS service so that you can always used a fixed name such as http://yourname.dynamic-dns-provider.com:8080/

share|improve this answer
    
ok, it looks like I'm doing all this but am still receiving a 'connection has timed out' message. url set to 123.45.76.89:8080 (replacing values from whatsmyip.com). (if you can like my question that may give me the points I need to upload a picture, then I can post my settings!, but they do look similar to what you have posted above) –  Twisted Inferno Sep 4 '12 at 13:45
    
@TwistedInferno: If you edit your question and add the URL of an image, some helpful passerby will convert it to an embedded image for you. –  RedGrittyBrick Sep 4 '12 at 13:47
    
Thanks, I just added the settings by text as that was easier, as you can see they are very similar to yours. Seems like I'm doing everything correctly but it doesn't like something. I feel like I understand things a bit better now though, a http request comes into my external ip, that forwards the request to my internal ip if the port number specified equals the one set up in the port forwarding list it will be passed through to my computer. Can you think of anything else, I have disabled my windows firewall and I can access the website using localhost. –  Twisted Inferno Sep 4 '12 at 13:53
    
Where you have "Translate to: 80 80" does that mean "80" or "8080"? –  RedGrittyBrick Sep 4 '12 at 14:01
    
80 - 80 that is automatically added for me and I think is intended to mean between port 80 and port 80. I have just got this working when removing the port number from the url (using port 80 by default) forwarding to port 80 of my machine. I guess that's fine but it would be nice to know why specifying a specific port does not work. Thanks for your help so far. –  Twisted Inferno Sep 4 '12 at 14:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.