Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way to modify the whitespace representation characters so I can change it from dots and dashes to something else?

Because I currently have whitespace characters being drawn always, it looks like this. I don't need it turned off, just interested in changing how it's represented.

enter image description here

I like how TextMate shows invisible characters but I would be ok with just being able to change the spaces to show a blank space instead of a dot.

enter image description here

share|improve this question
    
What do you want it changed to? – Joshua Sep 4 '12 at 19:16
    
@Joshua I would like to change the spaces to show a blank space instead of a dot. – Mike Grace Sep 5 '12 at 3:49
up vote 4 down vote accepted

No, as far as I can tell there's no way to customize the display of whitespace characters - it's dots and dashes, or nothing.
You can suggest this feature at Sublime Text's UserEcho forum or, if you're feeling ambitious, make a plugin that mimics TextMate's behavior.

share|improve this answer
    
Anyone has any ideas on how to do that on a plugin? It's very, very specific, and a quick look at the docs revealed no mention of this whatsoever... – Luan Nico Feb 20 at 1:03

This was answered on Stack Overview (Answer)

To view whitespace the setting is:

// Set to "none" to turn off drawing white space, "selection" to draw only the // white space within the selection, and "all" to draw all white space "draw_white_space": "selection",

You can see it if you go into Preferences->Settings Default. If you edit your user settings (Preferences->Settings - User) and add the line as per below, you should get what you want:

{
    "color_scheme": "Packages/Color Scheme - Default/Slush & Poppies.tmTheme",
    "font_size": 10,
    "draw_white_space": "all"
}

Remember the settings are JSON so no trailing commas.

share|improve this answer
    
"I don't need it turned off, just interested in changing how it's represented." – Mike Grace Sep 7 '12 at 1:49
    
This does not turn it off. It displays the spaces as DOTS and the tabs as DASHES. Did you actually try the settings. It worked just fine on my setup. I would be happy to provide screen captures. The original answer on Stack Overflow was accepted with 20+ upvotes. – DavidGrove Sep 7 '12 at 12:55
    
He already has dots and dashes – Dan R Sep 7 '12 at 14:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .