Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an 8GB SDHC card which I have used to upload pictures onto my Windows XP machine using an SD card reader ("SanDisk Ultra II"). I could also delete pictures and create folders on the card. I recently obtained a new computer that runs Windows 7 and, while I can view and upload the photos, I am unable to delete photos or create folders. When I attempt to do either of these two operations, the desired option does not appear in the menu ("Delete"/"New Folder"). Also, the shortcut keys do not work (e.g. the Delete key and Alt+F+W+F).

I have attempted to change the Properties from Read-only, but am greeted with a "media is write protected".

I should add that when I insert the Card Reader back into my Windows XP computer, I am granted full write permissions.

Why can't I modify the SD Card from Windows 7? And, related, how can I fix this issue?

Let me know if you have any additional questions.

share|improve this question
    
Its a laptop or desktop? –  Siva Charan Sep 5 '12 at 2:51
    
Both are laptops. –  David C Sep 5 '12 at 2:52
    
Have you tried using the card in another laptops which has windows 7? –  Siva Charan Sep 5 '12 at 3:05
    
Yes. Used in another laptop with Windows 7 and with the same results. –  David C Sep 5 '12 at 3:08
    
Is it formatted ntfs? if so that could cause problems, might need to add everyone with full permissions to the drive and the files if that is the case. Or pull the files off format it as fat32 then copy them back. –  Phillip R. Sep 5 '12 at 3:10
show 1 more comment

1 Answer

up vote 1 down vote accepted

I would look at the security tab in the SD properties. I don't think the format (FAT vs NTFS) would drive the issue.

  • Insert SD card, go to Computer
  • Right click the SD card icon and click on Properties
  • Click the security tab.
  • Click edit under the Group or user names display.
  • Click on Everyone (so that it is highlighted) then below in the permissions for Everyone area, tick Full Control.

I also found that the same options are available following the winding path of Properties > Sharing > Advanced Sharing > Permissions

share|improve this answer
    
I had been looking for the "Security Tab" earlier, but this is not present on whatever version of Windows 7 I have. I found that the same options are available following the winding path of Properties > Sharing > Advanced Sharing > Permissions. This seems to have done the trick, and so the above answer is essentially correct. Thanks! –  David C Sep 5 '12 at 3:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.