Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Copying files from the local system and pasting them on the server is an easy process for small files. However, I have not been able to do this for a few days now.

How can I enable this feature again? My local system is running Windows XP Service Pack 3 and my server is running Windows Server 2008.

share|improve this question
    
Are you on the same network - or is this via RDP? Are the folders still shared? Please provide more detail. –  Dave Rook Sep 5 '12 at 7:43
    
No it is on RDP. I just want to copy and paste the sql queries. –  Arun Kumar T Sep 5 '12 at 7:48
add comment

2 Answers

up vote 3 down vote accepted

update - Based upon comments, it appears Option 3 is has the most success.

Option 1

Click on the RDP connection and select options.

Under Local devices and resources make sure clipboard is checked.

Sometimes, it is useful to also click on the More button to bring across your drives (although this was not part of your original question). This way you can drag and drop files in Explorer (of the remote session) onto your local computer.

Option 2

Disable the internet security or firewall (sometimes not easy for bigger operations).

Option 3

I have learned how to solve it from this article:

http://brennan.offwhite.net/blog/2007/01/18/fixing-copypaste-for-remote-desktop-sessions/

To make it short: You have to stop the application called rdpclip.exe in your remote machine. Then you go to Run, and write rdpclip.exe to restart this app. The link between the clipboards is recovered.

Reason: The clipboard implements what is called " clipboard viewer chain " and is application-controlled, that is to say, that every application that is added to this chain is responsible of passing on notification messages to the next viewer in the chain, there are apps that don't pass the messages and this causes the problem (in Vista is solved).

Source

Option 4

  1. Log into the TS (on an account that has administrator rights)
  2. Run the Terminal Services Configuration program
  3. Select the Connections folder (under Terminal Services Configuration on the left window pane)
  4. Right-click on the RDP-tcp connection (in the right window pane) and select Properties.
  5. Click the Client Setting tab
  6. Un-tick the Clipboard Mapping option under the Disable the following: heading.

Source

share|improve this answer
    
Ya it is checked. But it won't works. –  Arun Kumar T Sep 5 '12 at 8:01
    
I would assume firewall - try disabling your Firewall / internet security to test (if possible). –  Dave Rook Sep 5 '12 at 8:03
    
I disabled my antivirus firewall. But it won't works –  Arun Kumar T Sep 5 '12 at 8:06
1  
It works when i try the option 3. Thanks for your help. –  Arun Kumar T Sep 5 '12 at 9:53
    
Option 3 recovered this functionality (that I normally take for granted); win8 local, win7 remote. –  Tim Lehner Jul 15 '13 at 19:22
add comment

If you have already checked Clipboard under Local Devices and Resources, but are still unable to copy and paste, uncheck it and connect to Remote Desktop. Now log off Remote Desktop, check the Clipboard option again under Local Devices and Resources, and recnnect to Remote Desktop. Now you will be able to copy and paste.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.