Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got a custom-built PC with these specs:

Upon building the PC, I overclocked the CPU (but never the GPU), and there were no problems for 1-2 months. Then I started getting crashes with one of these errors when doing anything that's computationally or graphically intensive:

NVIDIA Crash Dialog: Error code 3

NVIDIA Crash Dialog: Error code 7

I un-overclocked the CPU, but that hasn't fixed anything.

This is what the inside of my case looks like:

Inside of Case

I'd appreciate any guidance on resolving this problem. I did get some of the thermal paste on the graphics card when installing the aftermarket cooler, but there were no issues for a month or two.

Update

I did a clean install and the issue persisted - looks like it's a hardware issue. I will try removing/cleaning/reseating all the parts.

Update #2

I'm having similar issues in Ubuntu 12.04, so it's almost definitely hardware related, and not a driver bug.

Update #3

There were no crashes after removing the NVIDIA graphics card and using Intel on-board graphics.

share|improve this question
    
Ok 1. did you try updating the drivers? Weird things happen, update drivers or reinstall...2. where did you get thermal grease on? was it on the contacts for the pci slot? –  squinny Sep 5 '12 at 18:00
    
301.42 is the latest version, although I can try reinstalling it. I got the thermal paste on the surface of the graphics card, nowhere near the PCI slot contacts. Some just dripped onto the card, off the flat surfaces on which I was putting it and then gluing the heatsinks to. –  srunni Sep 5 '12 at 18:02
    
I really didn't think it would be from the grease. Try reinstalling first. Gotta trouble shoot this thing. If your still having issues it may be a faulty card i had a amd card run for about a month then out of no where random crashes...it was a faulty card. also curious how many watts is your psu? –  squinny Sep 5 '12 at 18:06
1  
@OliverSalzburg: I overclocked the CPU to about 4.2 GHz, but I don't believe that was the cause - I've run intensive CPU-bound processes for a week at a time without any issues. The crash only occurs when the GPU is taxed. Using the on-board graphics works fine (no crashes, although it is more sluggish, as expected). When I started experiencing the crashes, I hadn't touched the BIOS in weeks. There are only two errors I'm seeing, the code 3 and the code 7. –  srunni Sep 9 '12 at 17:05
2  
Try the graphics card with a different PC...to check if the problem is with card itself.. –  tumchaaditya Sep 10 '12 at 5:55
show 11 more comments

2 Answers

up vote 4 down vote accepted
+100

Overclocking for long periods can be very harmful in case of temperature highs, even short ones. You might have cooked up some part of the motherboard or some circuit inside that ultra-complex CPU (1.16 billion transistors).

The Core i7-2700k has the clock speed of 3.5 GHz, but thanks to the Intel Turbo Boost Technology it can achieve the max turbo frequency of 3.9 GHz, stopping turbo mode automatically when the temperature exceeds its limits. Over-clocking is uncalled for when Turbo Boost can do a much safer job.

In addition, the 2700's are actually handicapped Xeons. When Intel makes a CPU by etching billions of transistors onto a silicon wafer it is inevitable that some may fail. They get sorted out by testing, with the most perfect put in the Xeon bin for mission-critical purposes. The deciding criteria on whether a chip is classified as Xeon, i7, i5 or i3, is both the cache size and the highest electrical frequency it can tolerate.

Your 2700 is an i7, meaning that 100% of its cache (8MB) formed properly compared to 80% in an i5 (6MB). Its core and graphics clock can reliably cycle 100MHz and 250MHz higher then an i5 respectively, but less than a Xeon. This means that for your 2700, as the cache memory has fully passed the test, it is on electrical frequency tolerance that your I7 has failed to achieve the highest grade.

I hope you have been keeping an eye on the running temperature and have installed some software to alert you in case of a problem, such as SpeedFan, and have verified that all the S.M.A.R.T sensors were functional and have tested your hardware with IntelBurnTest.

To check out the hardware, I suggest replacing parts, starting with the CPU, then memory and so on. Test products that work by putting stress on the CPU and memory can be useful, but most will only detect hard failures.

[EDIT]

Some things to try in software :

In NVIDIA Control Panel --> Manage 3D Settings --> Global Settings, switch "Power Management Mode" to "Prefer Maximum Performance" rather than the default "Adaptive" setting.

Also about the OpenGL message "lost connection": You can find more information in this Microsoft page: Timeout Detection and Recovery of GPUs. In short, the workload sent to the Graphics Card was greater than what the graphics card can process in the normal timeout of two seconds.

Two possible solutions to try would be:

  1. Reduce the graphics workload if possible, such as rendering to a lower resolution or with less detail.
  2. Increase the timeout to allow more time to complete the really tough rendering parts. Microsoft provides the information on how to modify the registry to achieve this (although it accepts no responsibility for it).
share|improve this answer
    
Typical temperatures in SpeedFan hover around 30-40C. I haven't used IntelBurn Test, but after overclocking the CPU, I tested stability using Prime95. Note that there are no stability issues when running CPU-bound processes - I can run them for days with no issues. –  srunni Sep 8 '12 at 19:26
    
I added some more ideas above. Sorry about my tirade above, but overclocking such a beautiful CPU gets me going this way. –  harrymc Sep 9 '12 at 9:18
    
As I noted above, I already tried modifying the registry by adding the TdrDelay key. The only difference it made was that the machine froze up for a longer period of time before crashing. Also, I tried removing the NVIDIA card and ran the same GPU-intensive software with just onboard graphics. It was of course much more sluggish, but I encountered no more crashes. I'll try your other suggestions next. –  srunni Sep 9 '12 at 16:45
    
I tried changing the Power Management Mode to "Prefer Maximum Performance", but that didn't have any appreciable effect. I also tried resizing the window so that the rendering would be over a small portion of the screen, but that just meant more time before the crash occurred (10 seconds instead of 3 seconds). –  srunni Sep 9 '12 at 17:03
    
Have you tried another video card? –  harrymc Sep 9 '12 at 17:45
show 7 more comments

Some things to consider:

Fan speed control: Does the aftermarket cooler have a smaller fan that is supposed to turn faster (as compared to stock one)? Or it could just be a case of the default graphics driver settings trying to keep lower fan speed to limit the noise. Try using a program that allows you to change fan speed, and set it to much higher value.

Power input: Check if the graphics card is supplied power from a rail that also splits a lot to supply the hard disk etc. Unlikely to be a cause, but swapping around the rails used is easy to try.

Thermal paste: This may have been applied unevenly, and/or the layer was too thick and flaked off over time. Unfortunately, this isn't something you can test; only re-attach the cooler if you suspect this issue.

Rear case fan: Is this working well in drawing out the heat from the cpu? If not, the hot air from CPU cooler may be overloading the graphics cooler right next to it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.