Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm runnig for the first time SLES11(SP2) nad I have to install php5-devel on it, my problem is that it doesn't work with yast, I've download the rpm file and tried to install it, but it some how impossible to get this fone, because of the deppencies, any idea how this could be done ? thanks in advance

share|improve this question

1 Answer 1

For SLES11 SP2, you need the following repositories to install php5-devel

SLES11 Base Repo
SLE11-SP1-Pool
SLE11-SP1-Pool-Updates
SLE11-SP1-SDK
SLE11-SP1-SDK-Updates
SLE11-SP2-Pool
SLE11-SP2-Pool-Updates
SLE11-SP2-SDK
SLE11-SP2-SDK-Updates

If you upgrade to SLES11 SP3, you need a few less repositories:

No base product, SP1 or SP2 repos needed in this case.

SLE11-SP3-Pool
SLE11-SP3-Pool-Updates
SLE11-SP3-SDK
SLE11-SP3-SDK-Updates

You most probably don't want php5-devel (which is for php 5.2) but php53-devel (which is for php 5.3)

SLE11 SP 2 has both SLE11 SP 3 depecates php5-devel and recommends php53-devel

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.