Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried all new versions of LibreOffice, OpenOffice, NeoOffice. When I install them without any problems and then I try to launch them, I get the following error:

Process:         soffice.bin [1178]
Path:            /Applications/NeoOffice.app/Contents/MacOS/soffice.bin
Identifier:      org.neooffice.NeoOffice
Version:         3.2.1 Patch 0 (3.2.1 Patch 0 Intel [pluby:guibomacmini.local.])
Code Type:       X86 (Native)
Parent Process:  launchd [120]

Date/Time:       2012-09-06 13:18:45.562 +0200
OS Version:      Mac OS X 10.7.4 (11E53)
Report Version:  9

Interval Since Last Report:          21680 sec
Crashes Since Last Report:           10
Per-App Interval Since Last Report:  1 sec
Per-App Crashes Since Last Report:   1
Anonymous UUID:                      B1DA9D06-D4DB-4E02-90FE-11142CE5A8E8

Crashed Thread:  4

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000004

VM Regions Near 0x4:
--> __PAGEZERO             0000000000000000-0000000000001000 [    4K] ---/--- SM=NUL  /Applications/NeoOffice.app/Contents/MacOS/soffice.bin
    __TEXT                 0000000000001000-0000000000004000 [   12K] r-x/rwx SM=COW  /Applications/NeoOffice.app/Contents/MacOS/soffice.bin

Application Specific Information:
objc[1178]: garbage collection is OFF

Java information:
 Exception type: Bus Error (0xa) at pc=0000000004dcca8e

 Java VM: Java HotSpot(TM) Client VM (20.8-b03-424 mixed mode macosx-x86)

Current thread (000000000c21bc00):  JavaThread "Thread-1" [_thread_in_native, id=-1338478592, stack(00000000b0187000,00000000b0387000)]
Stack: [00000000b0187000,00000000b0387000]

### (...) I HAVE CUT QUITE A LOT HERE ###

External Modification Summary:
  Calls made by other processes targeting this process:
    task_for_pid: 3
    thread_create: 0
    thread_set_state: 0
  Calls made by this process:
    task_for_pid: 0
    thread_create: 0
    thread_set_state: 0
  Calls made by all processes on this machine:
    task_for_pid: 956
    thread_create: 1
    thread_set_state: 0

VM Region Summary:
ReadOnly portion of Libraries: Total=178.5M resident=110.7M(62%) swapped_out_or_unallocated=67.8M(38%)
Writable regions: Total=607.5M written=32.1M(5%) resident=54.8M(9%) swapped_out=0K(0%) unallocated=552.7M(91%)

REGION TYPE                      VIRTUAL
===========                      =======
ATS (font support)                 31.8M
CG backing stores                   512K
CG image                           1560K
CG raster data                      560K
CG shared images                   2360K
CoreGraphics                          8K
CoreServices                       1840K
Java                              234.8M
Java (reserved)                   132.1M        reserved VM address space (unallocated)
MALLOC                            146.3M
MALLOC guard page                    64K
Mach message                          8K
Memory tag=240                        4K
Memory tag=242                       12K
Stack                              96.2M
VM_ALLOCATE                        16.3M
__CI_BITMAP                          80K
__DATA                             10.2M
__DATA/__OBJC                       176K
__IMAGE                             528K
__IMPORT                            252K
__LINKEDIT                         48.8M
__OBJC                             1536K
__OBJC/__DATA                        64K
__PAGEZERO                            4K
__TEXT                            129.6M
__UNICODE                           544K
mapped file                       159.9M
shared memory                       308K
shared pmap                        10.6M
===========                      =======
TOTAL                               1.0G
TOTAL, minus reserved VM space    894.6M

Model: MacBookPro8,2, BootROM MBP81.0047.B27, 4 processors, Intel Core i7, 2.2 GHz, 8 GB, SMC 1.69f3
Graphics: AMD Radeon HD 6750M, AMD Radeon HD 6750M, PCIe, 512 MB
Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 512 MB
Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1333 MHz, 0x0702, 0x353132363459313333490000000048594E00
Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1333 MHz, 0x0702, 0x353132363459313333490000000048594E00
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (5.106.198.4.20)
Bluetooth: Version 4.0.5f11, 2 service, 11 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: KINGSTON SV100S2256G, 256.06 GB
Serial ATA Device: HL-DT-ST DVDRW  GS31N
USB Device: hub_device, 0x0424  (SMSC), 0x2513, 0xfa100000 / 3
USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 5
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821a, 0xfa113000 / 7
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0253, 0xfa120000 / 4
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0xfa200000 / 2
USB Device: hub_device, 0x0424  (SMSC), 0x2513, 0xfd100000 / 2
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd110000 / 3

I deleted profile settings and saved state from ~/Library/Application Support/LibreOffice/3/user and from ~/Library/Saved Application State/org.libreoffice etc whatever it is said. the same for openoffice. What's going on and how to fix this?

share|improve this question
    
Seems to me to be more of a Java issue than an Office issue. –  Radoo Sep 6 '12 at 12:32
    
I had the same impression –  mkk Sep 6 '12 at 16:59
    
I have Libre Office on Mountain Lion. Had it on Lion, and it worked. I don't have Java installed. That's why I believe it has something to do with Java. On the other hand, googling "Exception type: Bus Error (0xa)," it seems the issue is caused by the applications. Try upgrading to latest Java. That's all I can think of at this hour. –  Radoo Sep 6 '12 at 18:36
    
@Radoo I have installed the newest Java, I have removed references to java 1.5 and 1.4 in /System/Library/Frameworks/JavaVM.framework/Versions. Still the same –  mkk Sep 7 '12 at 7:58
    
any ideas? still not solved –  mkk Sep 18 '12 at 8:56
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.