Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have created a shortcut to the Google Chrome application on Windows XP. I have modified the target line in the shortcut such that it ends in the argument to start Chrome in incognito mode.

The modification is as such for the Target: "C:\Documents and Settings\username\Local Settings\Application Data\Google\Chrome\Application\chrome.exe" --incognito

Google Chrome Properties

The works until seemly Chrome updates and then I need to redo the above modification appending --incognito, again to the Target: line.

Is there a way to make this change more permanent, so that I can just do this one time and have a constant shortcut that's not going to randomly change back to a normal mode Chrome shortcut?

share|improve this question
up vote 1 down vote accepted

Probably either chrome or some other software is messing with the shortcut.

Options:

  • Try naming the shortcut differently than the Default name.

  • Create shortcut manually i.e. by right clicking on the desktop and select New>Shortcutand follow on screen instructions.

Update Proof method:
Alternatively you can use Batch file to launch chrome in Incognito mode. (This will not be affected by updates or anything like that)
Create a text file, paste following command to it, save it with extension .bat.

    C:\Documents and Settings\username\Local Settings\Application Data\Google\Chrome\Application\chrome.exe" --incognito
    EXIT

Double Click the file to launch chrome. (You can customize the icon to make it look like the chrome shortcut)

share|improve this answer
    
In the process of trying the first part, a new alias with a different name. – MrDaniel Sep 7 '12 at 16:06
    
@MrDaniel that's great, I hope you will also report results when done. – Ankit Mishra Sep 7 '12 at 16:10
    
Renaming / creating the shortcut with a different name worked. I called it "Chrome Incognito" – MrDaniel Sep 28 '12 at 11:39

Do it like this:

  • Open notepad copy/paste this code:

    @echo off
    cls
    start %userprofile%\AppData\Local\Google\Chrome\Application\Chrome.exe --incognito
    exit
  • But if you want to let it open a website in incognito window it should be like this:

    @echo off
    cls
    start %userprofile%\AppData\Local\Google\Chrome\Application\Chrome.exe --incognito "http://www.example.domain"
    exit

    Replace 'example' with your website address, And also 'domain' with your website's domain, Like '.com' '.org' '.tk'...

  • Save it as "Incognito".bat, replace with "Your File Name".bat.

share|improve this answer

The problem must be that chrome overwrites this particular link. The simplest solution would be to make another link (somewhere else, or with a different name) with your modification, that chrome wouldn't overwrite automatically every times it gets updated.

share|improve this answer
    
As in right clicking and creating a new shortcut with the shortcut wizard. More details would be appreciated. – MrDaniel Sep 6 '12 at 16:47
    
As in copy-pasting your shortcut (presumably in the same folder), renaming it "Chrome incognito", and then modifying the "target" the way you do with the normal shortcut (adding the --incognito parameter). – m4573r Sep 6 '12 at 16:52

i find this better as solution.

@echo off

start /d "c:\Program files\Google Chrome" Chrome.exe --incognito http://www.example.domain
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .