Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried to start an instance of my own (i am not root) sshd server on a remote machine , but it fails:

debug1: sshd version OpenSSH_4.3p2
debug1: read PEM private key done: type RSA
debug1: private host key: #0 type 1 RSA
debug1: setgroups() failed: Operation not permitted
debug1: rexec_argv[0]='/usr/sbin/sshd'
debug1: rexec_argv[1]='-d'
debug1: rexec_argv[2]='-f'
debug1: rexec_argv[3]='sshd_config'
debug1: rexec_argv[4]='-h'
debug1: rexec_argv[5]='ssh_host_rsa_key'
debug1: rexec_argv[6]='-p'
debug1: rexec_argv[7]='55000'
debug1: Bind to port 55000 on ::.
debug1: Bind to port 55000 on 0.0.0.0.
Bind to port 55000 on 0.0.0.0 failed: Address already in use.
Cannot bind any address.

Part of my sshd_config file:

#   $OpenBSD: sshd_config,v 1.73 2005/12/06 22:38:28 reyk Exp $

# This is the sshd server system-wide configuration file.  See
# sshd_config(5) for more information.

# This sshd was compiled with PATH=/usr/local/bin:/bin:/usr/bin

 # The strategy used for options in the default sshd_config shipped with
# OpenSSH is to specify options with their default value where
 # possible, but leave them commented.  Uncommented options change a
 # default value.

 Port 55000
 #Protocol 2,1
 Protocol 2
 #AddressFamily any
 #ListenAddress
 #ListenAddress ::

If i uncomment listener address and use any ip, obviously my own ip (172.16.13.126) it gives the following error:

Bind to port 55000 on 172.16.13.126 failed: Cannot assign requested address.
Cannot bind any address.
share|improve this question
1  
what's the result of sudo netstat -np | grep :55000? –  m4573r Sep 6 '12 at 15:14
    
i am not root user –  adnan kamili Sep 6 '12 at 15:32
    
How about netstat -n | grep :55000? If you see a listener, try running sshd on a different port. –  Flup May 17 '13 at 9:20

1 Answer 1

Bind to port 55000 on 0.0.0.0 failed: Address already in use.

Hey,

as the second to last line of your sshd output describes, the port 55000 seems to be taken by another process. You may try to configure another port in your sshd_config file. This reply here also gives a good explanation of how to run sshd as unprivileged user:

Thread: How do I run sshd as a particular user?

I haven't tried it, but the descriptions seems reasonable at first sight.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.