Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We all know that by doing port forwarding on the router, computers from outside the network are able, on the specified ports, to access internal computers by targeting the external IP.

I'm now replacing a TP-Link router with a D-link VDSL N 6740U router, (and copied over all the settings,) and I've noticed that one thing stopped working: With the TP-link router, you could access those port-forwarded computers from within the network, using the external IP, and they would be forwarded to the relevant computers. With the new D-Link router, it doesn't work.

You might be wondering, why would you want to use the external IP and port forwarding when you're inside the internal network anyway and can just access the internal IP? One example for why this is useful: You have an iPhone app that connects to a service on an internal computer. The iPhone app knows to connect to the external IP. When we put that iPhone inside the internal network (via WiFi), it suddenly stops working, because it can't access the service from the external IP anymore.

Is it an inherent property of D-Link routers that they do not allow accessing internal servers from inside the network by targeting the external IP? Or is there a way to make it work?

share|improve this question
    
I would think that is in the app configuration to change that behavior. –  Moab Sep 6 '12 at 15:32
    
I don't see how the app configuration would have anything to do with it. –  Ram Rachum Sep 6 '12 at 15:33
    
related: serverfault.com/questions/236262/… –  David Cary Dec 31 '12 at 18:07
add comment

1 Answer

TO enable port forwarding in D-link router do the followings...

Login to the router. select Advanced option from the top.

Actually it will take you to the Virtual Server setup page which will allow you to forward a public port of your router for redirection to Internal LAN IP.

Select a Check box from the left.(Give a tick mark :)

Then give the virtual server a Name Specify the Public port and select Protocl TCP/UDP You can also set the Schedule

In the second line specify private IP Address , Port and In Bound Filter

Here i am attaching a screen shot which will help you to better understand what i have described above.enter image description here

share|improve this answer
    
It seems like "Inbound Filter" is the one that solves my problem, but unfortunately on my model there's no such option. –  Ram Rachum Sep 6 '12 at 17:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.