Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Lenovo T430 running Linux Mint 13 (MATE):

joseph:~$ uname -a
Linux joseph-T430-LM 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

I installed Mint immediately after getting the laptop about two weeks ago, and have noticed that about once a day, the computer will completely freeze up- I can't use Ctrl+Alt+Backspace to restart X, I can't use Ctrl+Alt+F1 to get a text only terminal, can't move mouse, can't type, and if any music was playing it just gets stuck in about a 1-second loop. There is a Windows partition, but I haven't had any issues in Windows.

I couldn't find a common thread between the freezes, they were seemingly random (sometimes right after I clicked the mouse, sometimes not; sometimes with Pandora/flash being used, sometimes not, etc). I assume they're kernel panics since it completely locks up, but the laptop doesn't have a capslock or scroll lock LED. It is on a dock and I do have a USB keyboard, but the scroll lock/capslock lights do not flash when it happens (not sure if this is indicating its not a kernel panic, or if the kernel panic just wouldn't illuminate the LEDs on a usb keyboard attached to a laptop dock).

This was annoying but not terrible. However, I've found a way to reproduce it. I have a particular CSV file that when I open up in LibreOffice Calc and scroll around, the same thing happens- complete lock up. I really need to use this file, so I'd like to fix the issue, but at the least it's given me a test case to work with.

So, having a case where I can cause this issue, what can I do to better find out what's going on? I've looked in /var/log/syslog but haven't found anything seemingly useful. Any thoughts?

share|improve this question
    
Seems like you have uncovered an issue that causes the system to freeze. This is not a kernel panic, which would produce a stack trace, register & memory dump and other messages on the console. Congrats on finding a way to reproduce this. You could try starting the app with strace calc (or whatever) from a terminal shell to see if you can identify the system operation(s) that wedges the system. You'll need to keep the terminal visible of course. –  sawdust Sep 6 '12 at 19:22
    
If you have another PC, you should try to ping this Thinkpad to test if it's just the user interfaces or if the kernel is totally wedged. –  sawdust Sep 6 '12 at 19:34
    
I just tried the ping suggestion, and the Thinkpad does stop responding to pings as soon as it freezes up. I also tried strace, but once Libreoffice is fully loaded, it stops giving output in my terminal, even if I load the file and start scrolling around. There is tons of output while the program is loading, though. –  Joseph Sep 6 '12 at 19:43
    
Once you've swiched to the console, can you go to other ttys with alt+f8 9 10 12? Can you publish that csv? What's your libreoffice version? –  ott-- Sep 6 '12 at 19:46
    
Ott- I'm not able to do anything once the freeze occurs, including switching to other TTYs (text only or GUI). LibreOffice version is 3.5. I cannot publish this CSV file, but I can try to get a file that will cause the crash that I can publish. Like I said, this is not the only thing causing freezes, but it is one thing I can use to consistently cause the freeze. –  Joseph Sep 6 '12 at 19:49

2 Answers 2

I have had the same problem for several weeks now with a Lenovo X230 and Linux Mint 13 Mate with the very same symptoms (complete freeze with no console, ping, keyboard, nothing visible in logs).

I just installed the freshly released Mint 14 with a 3.5 kernel and that seems to work more stable. I also did not use encrypted home (ecryptfs) this time. I think the problem has to do with the 3.2 kernel on this hardware, probably also the 64bit version. Also see this thread here https://bugs.launchpad.net/ubuntu/+source/linux/+bug/999910

Have you checked your RAM? Try running memtest86+ from the boot menu. Lenovo support also has a test suite which you can either access from the BIOS or download as bootable image. Also make sure you have upgraded to the latest BIOS.

You can also try to reproduce the problem by filling up memory. stress is a nice tool for doing that or see this thread here which links to a script for filling memory very precisely https://bugs.launchpad.net/ubuntu/+source/linux/+bug/159356

share|improve this answer

Try updating your system (and reboot). The kernel version you are reporting (3.2.0-23-generic) has been around for a while now and has received many updates since. This also indicates you haven't been running updates for stuff in user land as well.

share|improve this answer
    
Unfortunately, seems like the problem is still here, with kernel updated to 3.2.0-30-generic. :[ –  Joseph Sep 19 '12 at 17:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.