Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a HP Microserver at home running Windows 7 and it sits behind a BT Infinity HomeHub Router.

Basically I followed the instructions here.

And then on my router I allowed the following to my server:

TCP 1723-1723 1723-1723
UDP 500-500 500-500
TCP 170-1701 1701-1701

However I can't get my phone (Galaxy Nexus) nor my iPad to connect to the VPN. I've done a ping test and I can resolve the IP. I'm using dyndns if that makes any difference, however I direct IP to my home network doesnt work either

Any ideas?

I get these messages on my servers event logs

The following error occurred in the Point to Point Protocol module on port: VPN3-1, UserName: MediaServer\vpn. The remote computer does not support the required data encryption type.

CoId={NA}: The user MediaServer\vpn connected to port VPN3-1 has been disconnected because no network protocols were successfully negotiated.

share|improve this question

migrated from serverfault.com Sep 6 '12 at 22:48

This question came from our site for system and network administrators.

I was also getting the following event log system error:

CoId={NA}: The user *** connected to port VPN3-1 has been disconnected because no network protocols were successfully negotiated.

I was able to get rid of the error thanks to K20GH's comment. Here are the steps I followed:

  1. Right-click the network icon in the notification area and select "Open Network and Sharing Center"
  2. Click "Change adapter settings"
  3. Right-click "Incoming connections" and select Properties
  4. On the Networking tab, select IPv4 and click Properties
  5. Select "Specify IP addresses" and enter a range of IP addresses

Android VPN client is able to connect successfully now to my Windows 7 laptop after doing the above.

share|improve this answer

You need to permit the GRE protocol many low-end routers don't support this, or only support this when you set the VPN server as the 'DMZ' device.

share|improve this answer
    
I've added the server as the DMZ device, however the connection gets rejected immediately now – K20GH Sep 6 '12 at 22:29
    
That is good, now check the event logs on your 'server'. – Zoredache Sep 6 '12 at 22:32
    
I appear to have these messages - see updated question – K20GH Sep 6 '12 at 22:38
    
Done it From Network Connections Right Click "Server Name"(local) Select Properties Select IP Tab Under IP address assignment select "Static Address Pool" and assign a pool of ip addresses from within the range of the IP addresses available from the DHCP server. After doing this I am able to connect. – K20GH Sep 6 '12 at 22:46
    
@K20GH Can you add your solution here as an "answer" so that it can be accepted? – JoshP Sep 7 '12 at 13:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .